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Copyright 

The computer program ETABS and all associated documentation are proprietary and 
copyrighted products. Worldwide rights of ownership rest with Computers and 
Structures, Inc. Unlicensed use of the program or reproduction of the documentation in 
any form, without prior written authorization from Computers and Structures, Inc., is 
explicitly prohibited. 
 
Further information and copies of this documentation may be obtained from: 

 
CSI Educational Services 

Computers and Structures, Inc. 
1995 University Avenue 

Berkeley, California  94704  USA 
 

Phone: (510) 845-2177 
FAX: (510) 845-4096 

e-mail: education@csiberkeley.com (for general questions) 
e-mail: support@csiberkeley.com (for technical support questions) 

web: http://www.csiedu.com 
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Introduction 

This lecture is generally geared towards the intermediate user level of ETABS. However, 
if you have never used ETABS before, do not be set back. We have designed this course 
in such a way that even the inexperienced ETABS user will have no problem following 
along. All of the examples that we present (except for the few real life models in the 
beginning) will be drawn from scratch to exhibit the most general and common modeling 
techniques mentioned above. 
 
We have chosen five examples that we will describe in the presentation. In these seminar 
notes, you will find descriptions, computer model definitions, and results for each 
example. As we present each example, please feel free to follow along. 
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EXAMPLE I 
Flexural Design Verification - Rectangular   
Concrete Beam  
 

  

 

Description 

This example verifies a flexural beam seismic design performed in ETABS. The model is 
a one-bay, one-story frame with two concrete columns hinged at the base with a 
continuous concrete beam in between. The beam has a point load at a distance of 10 ft 
from the left support of the frame as shown in Figure 1-1.  The beam moment can be 
computed analytically. The data consider for this problem are shown below. The total 
factored moments are compared with ETABS results. After the analysis was completed, a 
concrete frame design was performed using the ACI 318-99 code. The design 
longitudinal reinforcements are compared in Figure 1-3. 
 
 
Computer Model Definition 

The structure is a one-story concrete frame structure. Each bay is spaced 24 feet apart. 
Kip-inch-second units are used.  To see frame geometry, please refer to Figure 1-1. 

Other parameters associated with the structure are as follows:   

Clear span of beam, L    = 288 in 
Overall depth, h     = 30 in 
Width of beam, b     = 18 in 
Depth of Tensile Reinf., dc   = 4.5 in 
Effective depth, d    = 25.5 in 
Depth of comp. Reinf. , do   = 4.5 in 
Concrete strength, f’c     = 4000 psi 
Yield strength of steel, fy   = 60000 psi 
Concrete unit weight, Wc   = 0 pcf 
Modulus of elasticity, Ec   = 3600 ksi 
Modulus of elasticity, Es   = 29000 ksi 
Poisson's ratio, v    = 0 
Dead load, P      = 30 Kips 
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Figure 1-1 One Story Concrete Frame 

 
 

 
In Figure 1-2, you will see the factored moments used to determine the amount of steel 
required in the concrete beam. Complete hand calculations will be illustrated using the 
ACI-318-99 concrete code.  These hand calculations are compared and verified using 
ETABS. Please see Figure 1-3 for results.  In this example, we will consider a sway 
ordinary case. 

 
 
 

Point B 
(Kip-in) 

Point E 
(Kip-in) 

Point C 
(Kip-in) 

-545.98 2254.02 -545.98 

 
 

Figure 1-2 Frame Moment Chart
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First, calculated below is the minimum area of steel required as well as amax. 
 

 
 
 

Next, the area of steel for Points B, C and E will be calculated using the moments 
displayed in Figure 1-2.   
 
Point B – Sway Ordinary 
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Point E – Sway Ordinary 
    

    
 
 

 
Point C – Sway Ordinary
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 Comparison of Results 
 

The hand calculated flexural reinforcement is shown in Figure 1-3 for the seismic 
design of a Sway Ordinary type frame. The design flexural reinforcement is also 
compared calculated by ETABS is also shown in Figure 1-3.   
 

 
 

Steel (in2) At point B 

ETABS Top 
 Bottom 

0.533 
0 

Calculated Top  
Bottom 

0.533 
0 

Steel (in2) At point E  

ETABS Top 
 Bottom 

0  
1.692 

Calculated 
Top 

 Bottom 
0  

1.692 

Steel (in2) At point C  

ETABS Top  
Bottom 

0.533 
 0 

Calculated   Top 
 Bottom 

0.533 
 0 

   
 
  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1-3 Longitudinal Reinforcement Comparison 
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EXAMPLE II 
Verification of Uniaxial Rectangular 
Column Design  
 

  

 

Description 

This example verifies a concrete column design performed in ETABS. The square 
reinforced concrete column has a service dead and live load of 320 and 190 kips 
respectively. Column size is set at 18 in. by 18 in. 
 
 

Computer Model Definition 

Parameters associated with the concrete column are as follows:   

Length of column, l     = 8.5 ft 
Width of beam, b     = 18 in 
Column dimension, h    = 18 in 
Column dimension, b    = 18 in 
Clear length to rebar, d’   = 2.5 in 
Concrete strength, f’c     = 4000 psi 
Yield strength of steel, fy   = 60000 psi 
Effective depth, d    = 18 in 
Dead Load, Pd     = 320 kips 
Live load, Pl     = 190 kips 
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Pd= 320k
Pl =190k

 
 

Figure 2-1 3D Extruded View of Column 
 
Calculation of Steel 
 
 
The neutral axis for the balance failure condition is found out by using the following 
formula: 
 

 
We know, 
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Depth of stress block: 
  

    
 
Concrete Compression Force:    
           

  
Stress in compression steel: 

 
 
 
If compression steel is within the compression block: 
 

           
 
Stress in the tension steel is: 
 

          
                                        
Tension zone steel: 
 

   
 
Compression zone steel: 
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Load Capacity for balance condition:   
 

  
   
 
 
Moment Capacity for balanced condition: 

 

 
 
Top Compression point load: 
 

 
 

Top Tension point load: 
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Shown below are the interaction values for different steel ratios: 
 

Steel ratio: 1%  Steel ratio: 2%  

P (Kip)  M (Kip-ft) P (Kip)  M(Kip-ft)  

719.591  0  822.2861 0  

719.591  83.5722  822.2861 109.015  

665.7468  133.3046  735.2045 165.2148  

562.2896 170.3947  615.7054 210.9942  

452.1777  196.225  482.8973 249.1183  

330.1871  213.6252  326.3315 285.2468  

260.3881  200.9692  253.542  270.9709  

182.3767  175.1825  164.3279 239.116  

93.1626  134.6454  61.4575  217.3917  

-52.538  78.6256  -190.9728 98.4101  

-174.96  0  -349.92  0  

 
Figure 2-2 Interaction Diagram Values 

 
 

The design load for this column is: 
 
   P = 1.4(320 kips) + 1.7(190 kips) = 770 kips 
 
 
 
The Capacity ratio calculations for the concrete column are as follows: 
 
 1% steel:  Ratio = 770 kips / 719.5 kips = 1.0714 
 
 2% steel:  Ratio = 770 kips / 822.28 kips = 0.9376 
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Figure 2-3 Interaction Diagram Values  
 

 
Finally, from Figure 2-3, we can see that when the Capacity ratio is 1, the corresponding 
Steel ratio is 1.53%. Therefore: 
   

 
 
 
 
The design flexural reinforcement is compared in Figure 2-4.  As you can see, the results 
are nearly equal. 

 
Method Steel area (in2) 

ETABS 4.946 

Calculated 4.968 

 
Figure 2-4 Flexural Reinforcement Comparisons
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EXAMPLE III General Modeling Techniques –  
Three Story L-Shaped Concrete Frame  

  

Description 

This is a three-story L-shaped model, subjected to vertical static loading and computer-
generated earthquake loading per the 1997 Uniform Building Code.  The structure 
consists of concrete beams and columns along with a concrete slab on every level. There 
is an elevator core located in the middle of the building. 

Significant Options of ETABS Exemplified 

� Integrated Object Based Concrete Building Models 

� Auto Gravity Load Transfers 

� Auto Gravity Load Auto Lateral Wind and Seismic 

� Panel Zone Deformations 

� Special Modeling of Concrete Floor Systems 

� Shear Wall Design- Auto Loading Combinations- Design Groups 

� Reference Lines and Reference Planes 

� Pier/Spandrel Assignments 

� Elevator Cores and Walls with Openings and Curved Shear Walls 

� Complex 2D and 3D Shear Walls and Beam Column Frames 

� Design for Torsion Effects in 3D Walls 

� Creating Complex Reinforced Concrete Sections 

� Rigid, Semi-rigid and Flexible Floor Diaphragms 

� Cracked Properties and Lateral Drift Control 

� Auto Line Constraints 

� Centers of Rigidity, P-Delta and Mass Source 
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Computer Model Definition 

The structure is an L-shaped concrete frame structure. Each bay is spaced 24 feet apart. 
Kip-inch-second units are used.  The modulus of elasticity used for concrete is 3600 ksi. 
To see frame geometry, please refer to Figure 3-2. 

Other parameters associated with the structure are as follows:   

Coefficient of Thermal Expansion  = 6.500E-06 
Poisson's ratio     = 0.3  
Concrete Compression Strength, f’c   = 4 ksi 
Bending Reinforcement Yield Stress, fy = 60 ksi 

    Slab Properties: 
  
         Slab Thickness (Bending)   = 12 in 
 Slab Thickness (Membrane)   = 12in 
    
  Building Loads: 

   
 Live Load   Roof  = 25 psf    
     Story 2  = 75 psf 
     Story 1  = 75 psf 
 
           Corridor Live Load (non-reducible) 

Roof  = 100 psf    
     Story 2  = 100 psf 
     Story 1  = 100 psf 
 
For the UBC97 seismic load analysis, the following code parameters associated 
with the structure are as follows: 

  UBC Seismic zone factor, Z    = 0.40  
UBC Soil Profile Type     = SC   
UBC Importance factor, I     = 1.0 
UBC Overstrength Factor    = 8.5 
UBC coefficient Ct     = 0.035 
UBC Near source Factor, Seismic Source Type = B 

          Distance to Source     = 15 km 
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Gridline Generation  

Go to File -> New Model-> enter the number of lines in the X direction (6). Do the same 
for the Y direction (5).  Spacing in the X and Y direction is 24 feet. It is a 3-story 
structure with 12 ft story heights. Click on the Custom Grid Spacing option and click on 
Edit Grid. Select the Display Grids as Spacing option. For Grid ID E, enter 216 in. as the 
spacing. For Grid ID 4, enter 216 in. as the spacing. The Define Grid Data box should 
look like Figure 3-1: 

 

 

Figure 3-1 Grid Data 
 

To create this model, go to the Roof plan. In the bottom right hand corner of the screen, 
select the Similar Stories option. This will create objects drawn in plan to occur at all 
story levels designated as similar to the level where the object is drawn. An assignment 
made to an object in a plan view also occurs at all levels designated as similar to the story 
where the assignment is actually made where there is an object of the same type in the 
same plan location as the selected object. When an object is selected in plan view, objects 
of the same type in the same location at different story levels that are designated as 
similar to the story where the selection is actually made are also selected.  Go to edit 
story data to change similar story settings. 
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Draw Wall Objects  

The Draw menu -> Draw Area Objects -> Create Walls in Region or at Clicks 
(plan) command works in two ways. Click on any grid line (in plan view) and a 
wall below (area object) is drawn on that grid line between the two adjacent 
intersecting grid lines from the same coordinate/grid system. Depress and hold 
down the left button on your mouse. While keeping the left button depressed, drag 
the mouse to "rubber band" a window around one or more grid line segments. 
Then release the left mouse button. Area objects (walls below) are automatically 
placed at each grid line segment included in the "rubber band" window. The term 
grid line segment in this paragraph means that portion of a grid line that is 
between the two adjacent intersecting grid lines from the same coordinate/grid 
system. Draw single bay walls on Grid lines A, 4,1 and E. (see Figure 3-2). 

Draw Elevator Core 

Before drawing the elevator core, click on the Snap to Fine Grid button. (or use 
Draw-> Snap to-> Fine grid). This option snaps to an invisible grid of points. The 
spacing of the points is controlled by the Plan Fine Grid Spacing Item that is 
available under the Options menu -> Preferences -> Dimensions/Tolerances 
command. This feature works in plan view only. It does not work in elevation or 
three-dimensional views. To create the elevator core, go to Draw->Draw Area 
Objects-> Draw Walls. Draw an E shaped elevator core as shown on Figure 3-2: 

 

Wall Object 

Elevator Core Walls 

 
Figure 3-2 Walls and Elevator Core Layout 
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Reference Lines and Planes 
 

Next, create reference lines along the front of the elevator core (gridline 2).  
Reference lines are vertical lines at user-specified global X and Y coordinates. 
The reference lines are useful for snapping when drawing objects in elevation or 
plan view. Reference lines appear as points in plan view. See Figure 3-2. Right 
click the mouse and select the Create Reference Lines on Plan option. On Gridline 
2, click on the front edges on the elevator core creating reference lines every 4 
feet. (the fine grid spacing default).  
 
Reference planes are horizontal planes at user-specified Z-ordinates. The main 
purpose of those planes is to provide a horizontal plane/line that you can snap to 
when drawing objects in elevation views. You can also view reference planes in a 
plan view. This option can be useful for adding mezzanine-type framing when 
you have not specified the mezzanine as a story level in the story data.  In this 
case, the reference planes will signify the top elevation of the openings to be 
created in our shear walls. Go to Edit-> Edit Reference Planes-> and enter 
elevations of 8ft, 20ft and 32 ft and click OK.  
 

Draw Shear Wall/ Assign Pier and Spandrel Labels 
 
To draw the shear wall, go to Elevation 2 and you will see all of the reference 
lines and planes you have just created. Go to Draw->Draw Area Objects->Create 
Areas at Clicks, depress and hold down the left button on your mouse. While 
keeping the left button depressed, drag the mouse to "rubber band" a window 
around gridline B and C, then release the left mouse button. Area objects (walls 
below) are automatically placed at each grid line segment included in the "rubber 
band" window. The term grid line segment in this paragraph means that portion of 
a grid line that is between the two adjacent intersecting grid lines from the same 
coordinate/grid system. Delete the areas that represent the elevator doors. Please 
refer to Figure 3-3. 
 
A wall pier or spandrel can be made up from a combination of both area objects 
(shell elements) and line objects (frame elements). To get output forces reported 
for wall piers or to design wall piers, you must first define them. Define a wall 
pier by selecting all of the line and/or area objects that make up the pier and 
assigning them the same pier label. This can be done by going to Assign-
>Shell/Area->Pier Label or Spandrel Label.  Assign Pier and Spandrel labels for 
the shear wall on Elevation 2. See Figure 3-3. 

Although the assignment of spandrel labels is made separately to line and area 
objects (when the spandrel is made up of both), additions, changes or deletions of 
available spandrel names do not need to be made separately (i.e., you do not need 
to access the Spandrel/Pier Names for using both the Assign menu -> 
Frame/Line-> Spandrel/Pier Label and Assign menu -> Shell/Area -> 
Spandrel/Pier Label commands). 
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Figure 3-3 Elevation 2- Shear Wall with Openings 
 
 
Draw Column and Slab elements 

Go to the roof plan view and select the Similar Stories option as discussed 
beforehand. Activate the Draw menu -> Draw Line Objects -> Create Columns in 
Region or at Clicks (plan) command, select the ConcCol property. There are two 
ways you can draw the columns: 1) Left click at any location in a plan view to 
draw a column (vertical line object below). 2) Working in plan view, depress and 
hold down the left button on your mouse. While keeping the left button depressed 
drag your mouse to "rubber band" a window around one or more grid line 
intersections. Then release the left mouse button. Columns (vertical line objects 
below) are automatically placed at each grid line intersection of two grid lines in 
the same coordinate/grid system included in the "rubber band" window. Draw the 
columns at the 5 corners of the structure located at the intersections of gridlines 
A5, C5, C3, F3, F1 and A1. Next, draw columns at every grid intersection along 
the perimeter in between the specified corner columns. Refer to Figure 3-4.  

To draw an area object using the Draw menu -> Draw Area Objects -> Draw 
Areas command, select the SLAB property and left click once at the first corner 
point of the area, drag the mouse to the next corner point and left click, and so on 
to define each corner point of the area object. Note that as you drag the mouse a 
dashed line is visible indicating the current extent of the area object. When you 
reach the last corner point of the area object, double left click to finish the object 
or single left click and then press the Enter key on the keyboard. Areas object 
drawn using this command must have at least three corner points. Typically area 
objects are limited to no more than four corner points; however, there is no limit 
on the maximum number of corner points allowed for horizontal area objects.  
Draw the 6-sided, L-shaped area element with its corners at the same locations of 
the columns. Refer to Figure 3-4. 
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Draw Openings (Elevator Core) 

To draw an area object using the Draw menu > Draw Area Objects > Draw Areas 
command, select the OPENING property and left click once at the first corner 
point of the area, drag the mouse to the next corner point and left click, and so on 
to define each corner point of the area object. Select the Similar Stories option in 
the bottom right hand corner of the screen and draw two openings on the left and 
right side of gridline C in between gridlines 2 and 3.  Openings are designated 
with “X” marks in plan. Refer to figure 3-4.  

Draw Corridor Area Element 

In ETABS, users can assign a NULL property to an area element. NULL 
properties have no mass, weight or stiffness associated with them but have the 
ability to transfer load. Corridors can be draw as an area element with a NULL 
property assigned to them. To draw an area object using the Draw menu > Draw 
Area Objects > Draw Areas command, select the NULL property type. Select the 
Similar Stories option in the bottom right hand corner of the screen and draw an 
L-shaped corridor as shown in Figure 3-4. 

 

Corridor 

Elevator 
Opening 

Figure 3-4 Roof Plan View 



 
 

        “Optimized Modeling and Design of Concrete Structures using ETABS”  
 
 - 26 - 

 
 
Area Load Assignment 

Click the Define menu > Static Load Cases command, which brings up the 
Define Static Load Case Names form.  For this example, we are interested in 
creating three load cases:  

1. Lateral earthquake loads 

The Auto Lateral Load item is inactive unless the load type specified is 
Quake or Wind. When you specify the load type as Quake or Wind, 
the Auto Lateral Load drop-down box becomes active and you can 
choose None or one of several different code-specified loads that is 
then automatically created for the specified load case.  In this example, 
select the UBC 97 code and click ADD.  Next, click the Modify 
Lateral Load button and fill in parameters on the form as appropriate.   

2.   Live loads 

Type a live load case name and select the LIVE load type and click 
ADD.       

3. Non-Reducible live loads 

A live load that is specified as reducible is reduced automatically by 
ETABS for use in the design postprocessors. The live load reduction 
parameters are specified using the Options menu -> Preferences -> 
Live Load Reduction command. Type a reducible live load case name 
and select the REDUCE LIVE load type and click add. 

Next, select the floor area elements and click the Assign menu -> Shell/Areas Loads 
-> Uniform command to display the Uniform Surface Loads form. Enter a load 
value and select the Live load case, then select a direction from the drop-down list. 
Note that the Gravity direction is taken to be in the negative Global-Z direction. To 
enter a load in the gravity direction, enter a positive number if the direction is set to 
gravity. Next, select the corridor area elements and follow the same directions to 
assign a non-reducible live load to them.   
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Response Spectrum Analysis 

A response spectrum function is simply a list of period versus spectral 
acceleration values. In ETABS the acceleration values in the function are assumed 
to be normalized; that is, the functions themselves are not assumed to have units. 
Instead the units are associated with a scale factor that multiplies the function and 
is specified when you define the response spectrum case.  

Define response spectrum functions as follows: 

Click the Define menu > Response Spectrum Functions command to access the 
Define Response Spectrum Functions form. The Response Spectra area of this 
form lists the names of all the currently defined response spectrum functions.  
Select the UBC97 spectrum and click OK. 

After a response spectrum function has been defined, define a response spectrum 
case as follows: 

Click the Define menu > Response Spectrum Cases command to bring up the 
Define Response Spectra form. The Spectra area of the Define Response Spectrum 
form lists the names of all the currently defined response spectrum cases. 

Click on the Add New Spectrum button, which brings up the Response Spectrum 
Case Data form. Enter the structural damping as .05.  It is important that you 
understand the structural and function damping item. This item specifies modal 
damping that is present for all modes in the response spectrum analysis. Also, 
ETABS assumes that the response spectrum functions specified for the response 
spectrum case are all specified for this particular damping ratio. 

Select the CQC modal combination option. This is the Complete Quadratic 
Combination method described by Wilson, Kiureghian and Bayo (1981). This 
modal combination technique takes into account the statistical coupling between 
closely spaced modes caused by modal damping. Increasing the modal damping 
increases the coupling between closely spaced modes. If the modal damping is 0 
for all modes, then the CQC method degenerates to the SRSS method. 

Select the SRSS directional combination option.  For each displacement, force or 
stress quantity in the structure, modal combination produces a single, positive 
result for each direction of acceleration. These directional values for a given 
response quantity are combined to produce a single positive result. SRSS 
combines the directional results by taking the square root of the sum of their 
squares. All other input items remain unchanged. The results obtained using this 
method do not vary regardless of the excitation angle that you specify. This is the 
recommended method for directional combination and is the default. 
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Under the Input Response Spectra, specify any defined response spectrum function 
for each of the three local coordinate system directions of the response spectrum 
case. In this case, the spectrum name should be FUNC1. Click OK and this will 
conclude the response spectrum input for this model. 

Shear Wall Design 
 

   
 
Uniform Reinforcing Section: 
 

For flexural designs and/or checks, the program automatically (and 
internally) creates a Section Designer pier section of the same shape as the 
analysis section pier. Uniform reinforcing is placed in this pier. The 
reinforcing can be modified in the pier overwrites.  The Uniform 
Reinforcing Section pier may be planar or it may be three-dimensional. 
For shear design and boundary zone checks, the program automatically 
(and internally) breaks the analysis section pier up into planar legs and 
then performs the design on each leg separately and reports the results 
separately for each leg.  

 
 General Reinforcing Section: 
 

For flexural designs and/or checks, the pier geometry and the reinforcing 
are defined by the user in the Section Designer utility. The pier defined in 
Section Designer may be planar or it may be three-dimensional. For shear 
design and boundary zone checks, the program automatically (and 
internally) breaks the analysis section pier up into planar legs and then 
performs the design on each leg separately and reports the results 
separately for each leg.  

 
Simplified Pier Section:   

 
This pier section is defined in the pier design overwrites. The simplified 
section is defined by a length and a thickness. The length is in the pier 2-
axis direction and the thickness is in the pier 3-axis direction. In addition, 
you can, if desired, specify thickened edge members at one or both ends of 
the simplified pier section. You cannot specify reinforcing in a simplified 
section. Thus, the simplified section can only be used for design, not for 
checking user-specified sections. Simplified sections are always planar. 
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Using Section Designer 
 

Section Designer is a powerful utility that allows design of simple and complex 
cross sections of beams, columns and piers. Section properties, interaction surface 
and moment-curvature relationships can be displayed.  To utilize Section 
Designer, go to Define->Frame Section->Add SD Section->click on Section 
Designer. 

You can draw a poly shape by clicking the Draw menu -> Draw Poly Shape  
command.  A poly shape is defined by the coordinates of its corner points. To 
draw the Poly shape you simply click on the desired location of each corner point. 
You can complete the shape by double clicking on the last corner point, or by 
single clicking on the last point and then pressing the Enter key (or the Esc key) 
on your keyboard.    

Click the DONE button and in the SD Section Data box, give this section a 
name(C-SHAPE).   This section name will now be available in the Assign -> 
Frame Section dialogue box.   Draw a Polygon shape as shown in the Figure 3-5. 

 

 
   

Figure 3-5 Section Designer Module 
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You can now assign this section to a column element. Assign the C-SHAPE 
section to all of the columns at the intersection of Grid line C and 3. Select all off 
the columns at this intersection and go to Assign->Frame/Line->Frame Section-> 
and select the CSHAPE section. If you look at the plan view (See Figure 3-6), you 
can see that the actual section shape is displayed.  
 

 

Square Concrete 
Section 

C-SHAPE 
section 

 
Figure 3-6 Plan view 

 
Auto Line Constraint 
 

You can assign a specific mesh to area elements under Assign->Shell/Area->Area 
Object Mesh Options. In the model, all mesh points do not connect to the corner 
points of the shear walls. In typical finite element analysis, shell elements are 
connected to other elements at corner points only. When an element does not 
frame into the corner point of a shell element, but instead frames into the edge of 
the shell element, no connection exists between the element and the shell element. 
ETABS is able to perform the analysis in this fashion. However, ETABS also has 
the capability of using an auto line constraint. The ETABS auto line constraints 
feature allows you to specify that elements framing into the edge of a shell 
element be connected to the shell element. ETABS internally takes care of 
connection between the elements by constraining points lying along an edge of 
the shell element to move with that edge of the element. Additional information 
regarding the auto line constraint functionality in ETABS can be found in “Mesh 
Transitioning and Compatibility – The Automated Line Constraint in ETABS and 
SAP2000”. This paper can be found on page 57 of these notes. 
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Section Cut Forces 
 
There are two options available to define Section Cuts: 
 

1. The first option is to define the location of the cut.  Use the Define menu -
> Section Cuts command to obtain resultant forces acting at section cuts 
through a model. Define section cuts before or after an analysis is run; 
however, it is safest to wait until after the analysis has been run. Typically 
do not define section cuts, and more importantly, the groups used in the 
section cut definition, until all manual meshing of the model (if any) has 
been completed. If the groups are defined before manual meshing, some of 
the point objects that should be in the group may not yet be created. 

 
2.  The second option is to manually draw the section cut on any portion of 

the model. This can be by utilizing the Draw->Draw Section Cut option.   
You must make sure that the model has been analyzed and you are 
viewing a member force/stress diagram.  This can be found under Display-
> Show Member Force/Stress Diagram-> select either frame or shell 
forces.  This second option is used in this example to obtain section cuts 
forces.  

 
To obtain shell stress forces on Story 3 between Grid lines C and D, go to Draw -
> Draw Section Cut.  Draw a line parallel to Grid line D. The flashing line 
represents the section cut along Grid line D. Section Cut forces will now be 
visible on the screen. Please refer to Figure 3-7 and 3-8. 

 

 

Section Cut 

 
Figure 3-7 Stress Diagram (S12) for Earthquake Load Case 
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Figure 3-8 Section Cuts force output 
 
 
Results 

 
After you complete the Shear Wall Design portion of the program you can view 
the results in many different ways. Use the Design menu > Shear Wall Design > 
Display Design Info command to display on-screen output plotted directly on the 
model. All Shear Wall design output can be printed under File->Print Tables-
>Shear Wall Design. If desired, the screen graphics can then be printed using the 
File menu > Print Graphics command. Listed below are some of the design output 
options one can view: 
 

• Simplified pier longitudinal reinforcing 
• Simplified pier edge members 
• Section Designer pier reinforcing ratios 
• Section Designer pier D/C ratios 
• Spandrel longitudinal reinforcing 
• Shear reinforcing 
• Pier demand/capacity ratios 

 
When displaying design output information on the screen, right-click on the 
pier/spandrel to view more detailed information. See Figure 3-9: 
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Figure 3-9 Shear Wall Design Output 
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EXAMPLE IV Advanced Modeling Techniques – 
Eight Story Parking Garage Structure  

  

 

Description 

This is an eight-story parking garage structure with curved ramps located at each level. 
Each floor has a 12 ft story height.  Each bay is 24 feet long in the X-direction and 36 
feet long in the Y-direction. The structure is laterally supported by a curved shear wall 
system located at the edge of the ramp system.    

. 

Significant Options of ETABS Exemplified 

� Replication Features 

� Extrude Lines to Areas Feature 

� Straight and Spiral Parking Garage Ramp Generation 

� Curved Shear Wall Generation 

� Draw Developed Elevations 

� Auto Line Constraint Feature 

� Creation of OpenGL Views 

� Auto Gravity Load Auto Lateral Wind and Seismic 

� Rigid, Semi-rigid and Flexible Floor Diaphragm 

� Live Load Reduction Factors 

� Concrete Floor Diaphragm Shears & Section Cuts 

� Element Property Modification Factors 

� Chord and Collector Forces 

� Meshing Techniques for Shear Walls and Floors 
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Computer Model Definition 

Grid and Line Generation  

The structure is an 11-column line, 5-bay system.  Kip-inch-second units are used.  
Spacing in the X and Y direction is 24 and 36 feet respectively. It is an 8-story structure 
with 12 ft story heights. 

To create this model, go to elevation line 3.  Draw a line from Grid line A to Grid line C.  
Select this line, go to Edit-> Replicate-> Story Tab and select the EVEN story levels. 
(holding down the CTRL key while selecting levels). Draw a line from Grid line I to Grid 
line K and replicate this line on all odd story levels.  Next, draw a line starting at level 8 
diagonally down to level 7 connecting each line at every level. (In this example, it does 
not matter which beam size you select). Currently, the model should look like this: 

 
 

 
     
 

Figure 4-1 Elevation of Ramp Structure 
 
Ramp Generation 
 
Next, select all flat beams on every level and every other inclined beam element. Go to 
Edit -> Extrude Lines to Areas -> Linear.  In the Increment Data box, enter 36 feet for dy 
and number of replications = 2.  Now, select all of the flat beams again and the inclined 
beams that were not selected the first time. Perform the same extrusion application except 
use –36ft for dy. Your model should now look like Figure 4-2: 
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Figure 4-2 3-D View of Ramp Structure 
 
Circular Edge Ramp Generation 
 
Now, we are ready to create our circular ramp.  Go to Elevation A, and draw a line from a 
point in between Grid line 3 and 4 to Grid line 5. (Make sure snap to lines and edges is 
activated under Draw-> Snap to -> Line and Edges). Replicate this line on all even floors. 
Select all lines in Elevation A, go to Edit-> Extrude lines to Areas-> Radial tab. The 
ramp is a semi-circle so enter 10-degree angles extruded 18 times creating a 180-degree 
curved surface.  The total drop of the ramp is 2 stories or 288 in.  
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The ramp is rotated 
about Grid line 3 
and A. Y coordinate 
is 864. 

 
 

Figure 4-3 Extrude Lines to Areas Box 
 

After completing this step, your model should look like Figure 4-4: 
 

 
 

Figure 4-4 Circular Ramp Structure 
 
Curved Shear Wall Generation 
 
Now, we are interested in creating a curved shear wall surface around the edge of the 
circular ramp surface, which will run the full height of the structure.  Go to floor plan 8 
and select all stories the drop down box at the bottom right hand corner of the screen. 
This will create shear walls on all floors instead of just the 8th floor. Under View -> Set 
Building View Options -> de-select the toggle labeled invisible under point objects.  This 
will enable the user to view and snap to joints when creating the curved shear wall.  Go to 
the Draw ->Draw Area Objects -> Draw Walls and click on the joint located at the 
intersection of Grid line A and 5.  Keep clicking on every joint around the edge of the 
ramp. When you get half way around the semi-circle, you will need to go to floor plan 7 



          
 

“Optimized Modeling and Design of Concrete Structures using ETABS”  
 

- 39 - 

because the rest of the joints that are located below Story 8 cannot be seen. Complete the 
semi circle once you get to the intersection of Grid line 1 and A.   
 
Developed Elevation 
 
Developed elevations can simultaneously show multiple faces of the building in a single 
"unfolded" elevation view. To draw a developed elevation, from the menu select Draw-> 
Draw Developed Elevation Definition, type a name for the developed elevation in the edit 
box in the Developed Elevations area of the form and click on ‘Add New Name’.  Next, 
in floor plan 8, draw an elevation the same way you drew the curved shear wall, by 
clicking on the edge joints of the ramp until you’ve created a semi-circle again. To view 
the elevation, click the View menu-> Set elevation view and select the name of your 
Developed Elevation.   
 
Note: If the Options menu -> Window command is set to two or more windows and 
those windows are set to Plan or 3D View, the location of the developed elevation is 
illustrated with a cyan line (default) in the Plan and 3D view windows. Click on a couple 
of wall elements and delete them. This will create an opening in the curved shear wall 
element.  Your model should look like Figure 4-5: 
 
 
 
 

 
 
 

Figure 4-5 Circular Ramp Structure with Curved Shear Wall 
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EXAMPLE V Modeling/Design of Concrete Floor System – 
Two Way Flat Plate Slab System  

  

 

Description 

This is example 19.1 in the “Notes on ACI 318-02 Building Code Requirements for 
Structural Concrete” produced by the Portland Cement Association. This is a four-story 
concrete structure with a two-way slab without beams at each level. Each floor has a 9 ft 
story height.  Each bay is 14 feet long in the X-direction and 18 feet long in the Y-
direction. An intermediate floor will be exported to the SAFE program from ETABS for 
slab analysis and design purposes. 

. 

Significant Options of ETABS and SAFE Exemplified 

� Drawing and Detailing of Complex Slabs 

� Creating Plans and Elevations 

� Export/Import Options 

� Concrete Slab Design 

� Cracked Slab Deflection Control 

� Reinforcing Details & Bar Schedule 
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Computer Model Definition 

Grid and Line Generation  

The structure is a 4-column line, 3-bay system.  Kip-inch-second units are used. It is a 
four-story structure with 9 ft story heights. 

Other parameters associated with the structure are as follows:   

Coefficient of Thermal Expansion  = 6.500E-06 
Poisson's ratio     = 0.3  
Concrete Compression Strength, f’c   = 4 ksi 
Bending Reinforcement Yield Stress, fy = 60 ksi 

    Slab Properties: 
  
         Slab Thickness (Bending)   = 12 in 
 Slab Thickness (Membrane)   = 12in 
    
  Building Loads: 

   
 Live Load   Roof  = 40 psf 
     Story 3  = 40 psf    
     Story 2  = 40 psf 
     Story 1  = 40 psf 
 
           Superimposed Dead Load 

Roof  = 20 psf 
Story 3  = 20 psf    

     Story 2  = 20 psf 
      Story 1  = 20 psf 

 

To create this model, go to File->New Model.  Under the Grid Dimensions section, fill in 
the number of lines in the X and Y direction (4).  Enter the spacing in the X and Y 
direction. (14 ft and 18ft respectively).  Under the Story Dimensions section, fill in the 
number of stories (4) and story height (9ft).  Now, in the Add Structural Objects section,  
click on the Flab Slab button. The Flab Slab dialogue box appears on the screen.  Change 
the Drop Panel dimension to 16in. Enter a dead load of 20 psf and live load of 40 psf. 
Click OK to exit the Flab Slab dialogue box.  Click OK again to view the model.  The 
model should look like Figure 5-1: 
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Figure 5-1 3-D View of Two-Way Slab Model 
 

Import/Export options  

The File menu -> Export -> Save Story as SAFE.f2k Text File command saves the 
specified story level as a SAFE.f2k text input file. You can later import this file/model 
into SAFE.  

• Story to Export drop-down list:  Select the story level to export from the drop-
down list.  We are interested in selecting Story 3. 
 

• There are a few options available when exporting the model. They are:  
 

o Export Floor Loads Only 
o Export Floor Loads and Loads from Above 
o Export Floor Loads plus Column and Wall Distortions 

 
• Uncheck the check box and the item will not be included. Only one check box can 

be checked at a time. We are interested in exporting floor loads and loads from 
above. 
 

• Select Cases Button. Clicking this button displays the Select Loads form. 
Highlight the available loads to select or deselect them. Select the Dead and Live 
loads and click OK.  
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Now, ETABS prompts the user to give the model a name. Enter a model name and press 
SAVE. 

 
Next, open the SAFE program.  Under the File menu, select the Import -> SAFE .f2k file.  
Select the .f2k file and click OPEN.  The model should look like Figure 5-2: 
 
 

 
 

Figure 5-2 Plan View of Two-Way Slab Model 
 
You will the see the entire 3rd floor has now been imported into the SAFE program.  All 
of the material properties, slab properties and loads from the 3rd floor and above have 
been included in this model.  
 
Cracked Slab Analysis 
 
Under the Analyze menu -> Set Options command provides access to the Analysis 
Options form. The options available on the Analysis Options form depend on the 
Analysis Type selected. There are three options available: 

• Normal. When the Analysis Type is Normal, accept the default Maximum Mesh 
Dimension or enter a new value by typing in the edit box. The Maximum Mesh 
Dimension is described below. 
 

• Normal and Cracked Deflections. When the Analysis Type is Normal and 
Cracked Deflections, select the Interpolation Options for Slab Cracking Modifier 
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(linear, Quadratic, Cubic, or 4th order). Accept the default Maximum Mesh 
Dimension or enter a new value by typing in the edit box. The Maximum Mesh 
Dimension is described below. 
 

When the Specify Cracked Reinforcement button is clicked, SAFE displays the 
Reinforcing specification for cracked analysis form. 

The Reinforcing Specification for Cracking Analysis form is used to specify the 
rebar to be used in the cracking analysis. Note that the spreadsheet in the middle 
of the form displays a strip ID, the X and Y starting points for the rebar, the width 
and length of the rebar, and the location (top or bottom) of the rebar. The form has 
been designed to allow you to use the three options (Program Calculated, User 
Typical and User Other) in conjunction with one another to quickly tailor data 
entry to meet your specific needs. For example, if most, but not all, of the rebar 
can be calculated by SAFE, (1) click the Program Calculated button; (2) click the 
cell in the Reinf Type column for the row of data to be altered; (3) select the User 
Typical or User Other option; and (4) provide additional data input as described 
above for the User Typical or User Other options to modify those rebar that 
require specification other than the default. 

• Iterative for Uplift. When the Analysis Type is Iterative for Uplift, accept the 
default values for the maximum number of iterations and the convergence 
tolerance or enter new values by typing them directly in the edit boxes. This 
option is specifically needed to remove any tension when analyzing mat 
foundations.  Accept the default Maximum Mesh Dimension or enter a new value 
by typing in the edit box. The Maximum Mesh Dimension is described below. 

 
For this model, select the Normal and Cracked deflection option and click the OK button.  
We are now ready to analyze and design this slab.  Under the Analyze menu, click on the 
Run Analysis button.  SAFE will analyze the model three times. The first iteration is a 
regular elastic analysis. The second iteration is a cracked analysis due to dead load only.  
Finally the third iteration is a cracked analysis due to dead plus live loads.  After this is 
completed, the user can view the cracked analysis deflections under Display -> Show 
Deformed Shape and select the long-term cracked deflection button. 
 
Results 
 
We are now ready to run the design portion of the program.  Go to the Design menu and 
click on the Start Design button.  You will see your model in plan view showing the 
amount of steel required based upon the moment calculated.  Go to Design->Display 
Design Info and the Slab Reinforcing dialogue box will appear. We are interested in 
viewing the y-direction strip and determining the amount #4 bars required for the middle 
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strip.  After making these selections, the Slab Reinforcing dialogue box should look like 
Figure 5-3: 
 
 
 
 

 
 

Figure 5-3 Slab Reinforcing Dialogue Box 
 

Click the OK button and you will see the amount of #4 bars required in the Y-direction 
for each strip.  See Figure 5-4: 
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Figure 5-4 Slab Reinforcing for Y-Strip 

 
 
If you look at the middle strip in between grid lines B and C, you will that 3-#4 bars are 
required along the strip.  This result matches the result given in example 19.1 from the 
“Notes on ACI 318-02 Building Code Requirements for Structural Concrete” book.  
 
 
 
CSIDetailer 
 
CSiDetailer prepares detailed engineering drawings in accordance with detailing codes, 
such as ACI-315-99, and preferences set by the user. Those preferences may comply with 
building codes as well as be customized to meet additional requirements. 
 
CSiDetailer generates drawings from data generated through analysis and design 
completed using SAFE. The user is responsible for thoroughly examining and modifying 
the CSiDetailer-generated detailing and drawings. To facilitate modification, CSiDetailer 
can generate DXF and DWG files of the drawings. Those drawings then can be opened 
and edited using AutoCAD or other CAD software. 
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The basic process for generating engineering drawings using CSiDetailer involves using 
the output generated by SAFE and then using a variety of forms to set options and 
preferences to guide the detailing process. After the Detailer is activated, various views 
are added to the drawings and arranged automatically. The views and preferences can be 
altered by the user as required. The drawings can then be printed to a printer, or exported 
in DXF or DWG format for use by AutoCAD.   
 
After setting the preferences, click the Detailing menu > Start Detailer command to start 
CSiDetailer and display the Detailing Status form. As the program details the model, 
progress will be shown on the Detailing Status form. When the detailing is complete, the 
program will automatically generate all possible drawings and add them to the project 
file.  The main CSiDetailer window will display the File, Edit, View, Drawing, Tables, 
Options and Help menus.   
 
If the drawings need additional refinement, export them to an AutoCAD/CAD 
compatible format. Click the File menu -> Export Drawings command to display the 
Export Drawings form. Use the form to specify the format for the export and the 
drawings to be exported (current, all, or selected). The files may be exported in DXF or 
DWG file format. 
 
In Figure 5-5, you will see an example of the type of drawings that can be created by 
CSiDetailer: 
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Figure 5-5 CSiDetailer Slab Reinforcement 
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EXAMPLE VI Structural Dynamics –   
Time History Analysis  

  

 

Description 

This simple 2D frame example is used to illustrate the powerful time history feature in 
ETABS.  The purpose of this model is to show the change in deflection of a point for two 
separate load conditions. The first load condition consists of a 100 kip force applied to 
the center of the beam. Please see Figure 6-1.  The second load condition is the same 100 
kip load applied as a time history function. The load will be applied in a very short time 
frame, which will resemble an impact load. 

 

Significant Options of ETABS and SAFE Exemplified 

� Time History Functions 

� Time History Traces 

� Eigenvector Analysis 

 
Figure 6-1 2D view of Concrete Frame 
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Computer Model Definition 

The structure is a two column, one bay system.  Kip-inch-second units are used.  The 
columns have a height of 24 ft and the beam has a length of 24 ft.  The concrete beam 
section is a 12x18 rectangular member. The concrete column is an 18x18 square member. 
To assign a 100 kip load to the beam, select the beam, go to Assign -> frame line loads -> 
point loads.  Select the LIVE load case, then under the point loads section, enter a 
distance of .5 and a load of –100 kips. We have now defined the first load condition. 
 
Time History Function Definition 

A time history function may be (a) a list of time and function values or (b) a list of 
function values that are assumed to occur at equal spaced intervals. The function values 
in a time history function may be (a) ground acceleration values or (b) multipliers for 
specified load cases (force or displacement). 

Define a time history function as follows: 

1. Click the Define menu -> Time Functions command.  
2. When the Define Time History Functions form appears, select Add User Function 

and press the modify/show function button. A form reflecting the type of function 
will appear. Modify the values in the form as necessary. Enter the values shown in 
Figure 6-2: 
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Figure 6-2 Time History Function Form 
 
Time History Case Definition 
 
Click the Define menu -> Time History Cases command to define, modify, or delete a 
time history case. Note that you must have at least one time history function defined for 
this command to be active.  

1. Highlight an existing time history case in the History area of the form. 
 

2. Click the Modify button to access the Time History Case Data Form.  Use 
that form to make the desired modifications. 
 

3. Choose the Linear Analysis Type. In a linear time history analysis, all 
objects behave linearly. Only the linear properties assigned to link 
elements are considered in a linear time history analysis. In this example, 
we are not using any link elements. 
 

4. Click the modal damping button and enter .01. This assigns as 1% 
damping for all modes. This is a percent critical damping value. 
 

5. Enter 1000 as the number of output time steps. The number of output time 
steps is the number of equally spaced steps at which the output results are 
reported. Do not confuse this with the number of time steps in your input 
time history function. The number of output time steps can be different 
from the number of time steps in your input time history function. The 
number of output time steps times the output time step size is equal to the 
length of time over which output results are reported. 
 

6. Enter .002 as the output time step size. The output time step size is the 
time in seconds between each of the equally spaced output time steps. Do 
not confuse this with the time step size in your input time history function. 
The number of output time step size can be different from the input time 
step size in your input time history function. The number of output time 
steps time the output time step size is equal to the length of time over 
which output results are reported. 
 

7. Under the Load Assignments box, select the LIVE load case; select the 
STEP time history function and scale factor of 1. Press the ADD button 
and press OK. 
 

8. Before you run the analysis, select the beam, go to Edit -> divide lines and 
select the first option and divide beam into 4 elements. You will now have 
3 joints located at the quarter points of the beam element. 
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Results 
 
After you run the analysis, go to Display -> Show deformed shape -> select the LIVE 
load case and click OK. You will see the deflected shape of the frame due to the static 
100 kip applied load. Right click on the joint to see the deflection value.  You will see 
below that the deflection is .953 in. 
 
 
 

 
 

Figure 6-3 Joint Deflection 
 

 
 
Time History Traces 

After running a time history analysis, click the Display menu -> Show Time History 
Traces command to access the Time History Display Definition form. Use the form to 
specify the appropriate data to plot various time history curves. 

A time history trace is simply a plot of a vertical time history function versus a horizontal 
time history function. The vertical time history function can be any defined time history 
function. Although the horizontal time history function defaults to Time, it can be any 
defined time history function. 

When you click the Display menu -> Show Time History Traces command, ETABS 
automatically creates time history display functions for all selected objects. Use the Time 
History Display Definition form to define additional time history display functions as 
desired. To display the time history trace for a particular point, for example, it is easiest 
to select that joint before selecting the Display menu -> Show Time History Traces 
command. ETABS creates the time history display function automatically for that point. 
You can easily modify the component of displacement displayed if ETABS did not 
default to the one you want. 
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We are interested in the deflection value of joint 25 in this example. Add this joint to the 
Vertical function column in the Time History Traces dialogue box. Click the Define 
functions and select joint 25 and press Modify/Show TH function.  Make the sure the 
Displacement option is selected under the Vector Type. Select UZ under the Component 
box. We are now ready to view the time history traces. See Figure 6-4: 

 
 

 
 
 

Figure 6-4 Time History Trace Plot 
 
 
You can see that joint 25 has a maximum deflection of 1.19 inches for the time history 
load condition. As expected, the deflection for the time history load (impact load) is 
higher than the 100 kip static load (.93 in.) 
 
Now, go back to the Define->Time History Function->Show Function and decrease the 
amount of time the load is applied. Initially, the time values assigned were 0.0125 and 
0.025(see Figure 6-2). Change these values to 0.125 and 0.25 respectively. Click OK and 
run the analysis again. Click the Display menu -> Show Time History Traces command 
and look at the deflection for Joint 25 again. See Figure 6-5: 
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Figure 6-5 Time History Trace Plot 
 
You can see that joint 25 has a maximum deflection of 1.03 inches for the time history 
load condition. The deflection for the time history load (impact load) is only slightly 
higher than the 100 kip static load (.93 in.) 
 
Finally, go back to the Define->Time History Function->Show Function and drastically 
decrease the amount of time the load is applied one more time. This time change the time 
values assigned to 0.00125 and 0.0025 respectively. Click OK and run the analysis again. 
Click the Display menu -> Show Time History Traces command and look at the 
deflection for Joint 25 again. See Figure 6-6: 
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Figure 6-6 Time History Trace Plot 
 
You can see that joint 25 has a maximum deflection of .165 inches for the time history 
load condition. The deflection for the time history load (impact load) is only slightly 
higher than the 100 kip static load (.93 in.) 
 
For dynamic analysis, you can see the deflection values are directly dependent upon the 
amount of time the load has been applied. If the load is applied for a very short period of 
time, this results in a small deflection value. Conversely, if the load is applied for a 
longer period of time, the result is a larger deflection value as illustrated by this example. 
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MESH TRANSITIONING AND COMPATIBILITY 

THE AUTOMATED LINE CONSTRAINT IN ETABS & SAP2000 
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M. Iqbal Suharwardy, S.E., Ph.D., Director of Research & Development, Computers & Structures, Inc. 

 
 
In the application of the Finite Element Analysis Method, the most time consuming task 
is usually the creation and modification of the finite element mesh of the system. Not to 
mention the fact that creation of mesh transitions from coarse to fine meshes can be very 
tedious. Also matching up node points to create compatible meshes at intersecting planes, 
such as walls and floors can be very labor intensive. And even if the mesh generation is 
automated the mesh transitioning usually produces irregular or skewed elements that may 
perform poorly. This may have adverse effects on the design, especially in regions of 
stress concentration, such as in the vicinity of intersecting planes. 

The object based modeling environment of ETABS & SAP2000 clearly addresses these 
time-consuming shortcomings of the Finite Element Method. 

In the object-based modeling environment the Engineer generates the structural model by 
creating only a few large area objects that physically define the structural units such as 
wall panels, floors or ramps. The finite element mesh is not explicitly created by the user, 
but is automatically generated by assigning meshing parameters to the area objects. These 
parameters may include variables, such as mesh size, mesh spacing and mesh grading 
among others. With this capability the engineer can study the effects of mesh refinement 
by just defining a few control parameters. The new model with the desired level of 
refinement is thus created with minimal effort. 

If the meshes on common edges of adjacent area objects do not match up, automated line 
constraints are generated along those edges. These Line Constraints enforce displacement 
compatibility between the mismatched meshes of adjacent objects and eliminate the need 
for mesh transition elements. 

What makes this technology really powerful is that while making modifications to the 
model the Engineer need only be concerned about the few large physical objects of the 
structure. The modified finite element analytical model gets recreated automatically with 
any changes to the base objects.  

The following examples are designed to illustrate the power and practicality of this 
technology. 
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1EXAMPLE 1 

Simply Supported Plate (Mismatched Meshing) 

 

As illustrated in Figure 1, this is a model of a simply supported plate, which has been 
modeled in two different ways.  In one case the mesh is uniform across the plate and in 
the other case the mesh is fine on one half of the plate and coarse on the other half of the 
plate. In the latter case, an interpolating line constraint is automatically generated to 
enforce displacement compatibility between the adjacent halves of the plate where the 
mesh does mot match. As shown in the figure, correlation between the two models is 
very good. 

Matching 
Meshes 

(Uniform)

Mismatched 
Meshes

Fine Mesh Coarse Mesh

DEFORMED SHAPESSTRESS DIAGRAMS

Line   Constraint

 

 

Figure 1:  Simply Supported Plate with Mismatching Edges 
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EXAMPLE 2 

Curved Ramp Supported by Curved Wall 

This example, Figure 2, illustrates the use of Line Constraints to capture the interaction of 
a curved shear wall supporting a curved ramp. Notice that there are no joints at the points 
where the ramp element edges intersect the wall element edges. Displacement 
compatibility along the lines of intersection of the ramp and the wall is enforced 
automatically by the generation of Line Constraints along those lines. Notice how the 
application of Line Constraints allows the wall and ramp mesh to retain a simple 
rectangular (or quadrilateral) configuration. A conventional finite element model would 
be very irregular because it would need all the additional joints (and corresponding 
elements) to allow for the ramp element and wall element edge intersections. 

WALL & RAMP OBJECTS

INTERNAL MESHING

 

Figure 2:  Curved Ramp Supported by Curved Wall 
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EXAMPLE 3 

Floor Slab - Shear Wall Compatibility 

This example, Figure 3, illustrates a 3D Concrete Flat Plate Building with shear walls and 
an elevator core. Again, in this model, Line Constraints automatically appear at the lines 
where the   floor and wall objects intersect. This, of course, as in previous examples, will 
enforce displacement compatibility when mesh geometries do not match. As shown in the 
deformed shape of the Elevator Core, in many places the wall meshing does not match 
the floor meshing. All elements meeting at common edges, however, still show no 
displacement incompatibilities, even though the element nodes do not coincide. 

 

 

 

Figure 3:  Floor Slab - Shear Wall Compatibility 
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EXAMPLE 4 

Shear Wall – Spandrel Transition 

 

This example, Figure 4, models a Shear wall – Spandrel System, illustrating mesh 
transitioning from the spandrel to the shear wall. Line Constraints are generated as 
needed in any direction. In this case the Line Constraints are vertical as well as 
horizontal. 

 

WALL OBJECTS INTERNAL MESHING

 

 

Figure 4:  Shear Wall - Spandrel Transition 
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