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PREFACE

This lecture is generally geared towards the intermediate user level of ETABS. How-
ever, if you have never used ETABS before, do not be set back. We have designed this
course in such a way that even the inexperienced ETABS user will have no problem
following along. The end-to-end example that we present will be drawn from scratch
to exhibit the most general and common modeling techniques mentioned above.

The morning will be spent discussing general modeling techniques for steel
beams, columns, and braces. Part of the morning, as well as part of the afternoon
will be spent on Steel Frame and Composite Beam Design. We will finish the af-
ternoon presentation discussing the design and detailing of concrete foundations and
output creation of reports for submittal.

We have chosen a very specific end-to-end example that we willdescribe in
the presentation. In these seminar notes, you will find descriptions, computer model
definitions, and results for the steel structure. As we present the model, please feel free
to follow along.

iii
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PART I

General Modeling

I.1 Model Description
This is a ten-story steel braced building that contains two elevator cores at the center of
the structure. There are two stories of shear walls located at the bottom of the building.
Steel braces exist on certain levels on the outside bays of the structure. The building is
subjected to vertical static loading and computer-generated earthquake loading per the
2006 International Building Code. Automated wind loads arealso applied to the struc-
ture per the ASCE 7-02 code. The building consists of steel beams and columns along
with a concrete deck on every level. Please refer to Figure I.1 for a three dimensional
view of the structure.

I.2 New Model Creation: Import Grid and 3-D Model
using DXF File

The grid definition for this model contains Cartesian coordinates systems. The grid
spacing in the X and Y directions are non-uniform. In this case, it is easiest to import
an architectural grid from a .DXF file.

Click the File menu> Import > DXF File of Architecture Grid command to
access the DXF Import form. Locate the filename/path of the .DXF file to be imported
and click the Open button.

Use the drop-down boxes to select the DXF layer names that contains the lines
and insertion points in the DXF file as the ETABS corresponding elements. For this
model, we select the GRIDS layer and click OK. ETABS then imports the lines from

1
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2 CSI STEEL FRAME DESIGN SEMINAR

Figure I.1: 3D View of Structure
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PART I. GENERAL MODELING 3

any layer in the DXF file as ETABS grid lines.Note: Make sure that the gridlines
are drawn as a part of the GRIDS layer in the AutoCAD .DXF file.In the Coordinate
System box, choose the GLOBAL coordinate system for importing the file. Also select
the units askip-ft. Your grid system should look like Figure I.2. If you want to import
multiple grid systems, you could do so by following the same steps to import another
grid system to the same model.

Figure I.2: Architectural Grid

Right now, the model consists of a single story. To insert theadditional 15 stories
needed for the completion of the grid, go to Edit> Edit Story Data> Insert Story.
Enter the New Story Data and New Story Location as shown in Figure I.3:

Your model now contains 16 total stories. As you can see in Figure I.1, stories
4-5 are identical to each other; just as stories 11-13 are identical to each other. In this
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4 CSI STEEL FRAME DESIGN SEMINAR

Figure I.3: Insert New Story Dialogue Box

case, it would be beneficial to use the ‘Similar Stories’ option in ETABS. This means
when you draw an object in plan, this object will be drawn on all stories that have been
designated to be similar to that story. An assignment made toan object in a plan view
also occurs at all levels designated as similar to the story.When an object is selected in
plan view, objects of the same type in the same location at different story levels that are
designated as similar to the story where the selection is actually made are also selected.
If desired, change the similarity option in the drop-down box in the status bar at any
time in a plan view. When you are in an elevation view or a three-dimensional view,
the similar stories drop-down box displays the word “Inactive” to remind you that the
feature is inactive in these views. When you switch from planview to an elevation or
three-dimensional view and then back to a plan view, ETABS will retain the similarity
option that it last had in the drop-down box in the status bar for the previous plan view.
To activate the Similar Stories option, go to Edit> Edit Story Data> Edit Story. Make
changes (including story heights) as shown in Figure I.4:

Now, we can import the steel structure into ETABS. Click the File menu>
Import> DXF 3D Model command to access the DXF Import form. Use the form to
locate the filename/path of the .DXF file to be imported. Highlight the filename and
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PART I. GENERAL MODELING 5

Figure I.4: Edit Story Data Dialogue Box

click the Open button.

A form will appear where you can select DXF layers that contain entities that
will be imported into ETABS as column, beam, brace, floor, wall or ramp objects.
ETABS will import lines in the vertical plane as columns, lines in the horizontal plane
as beams and lines in inclined planes as braces. 3DFaces in the DXF file will be
imported as ramp objects if they are in the incline plane, walls if in the vertical plane,
and floors if in the horizontal plane. Polylines in horizontal planes will be imported
as floors. An option is available to select properties for thebeams, columns, braces,
walls, ramps and floors, which will be imported into ETABS as assignments.Select
the Centerlines, and Walls, layers to be imported into ETABSand click OK.

As shown in Figure I.5, the entire steel model has been imported into ETABS.
There are some default sections that have been assigned to the beams and columns.
The user will have to assign specific sections to all frame elements. In the next section,
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6 CSI STEEL FRAME DESIGN SEMINAR

the drawing tools will be used to create beams, columns, walls and brace elements.

Figure I.5: Imported Model from .DXF file

I.3 Model Creation Using the GUI (Steel Beams, Columns
and Braces)

ETABS provides an icon or button for virtually every command. These icons reside
in the toolbars located on the top and left side of the screen.For this model, all of
the steel beams and columns have been imported from a .DXF file. The braces will
be drawn in manually using the drawing tools. Many changes are typically made to a
model after it has been imported. Listed below are the most commonly used drawing
buttons.
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PART I. GENERAL MODELING 7

• Draw Lines

When drawing objects, a floating Properties of Object form will pop up. The
dialogue box shown in Figure I.6 pops up when you click on the Draw Lines
button. The user must select the line type, the section, moment releases (con-
tinuous or pinned), plan offsets and the drawing control type. The plan-offset
option automatically draws a line directly parallel to the line drawn. The user
just specifies the distance. The drawing control type allowsthe user to draw line
parallel to theX or Y -axis and draw a line with a fixed length or angle. For
some objects, moment releases, number of beams, spacing, orientation, bracing
configuration, and the like can be assigned.

Figure I.6: Beam Properties Dialogue Box

There are a few steps simple steps to follow when drawing a line element. First,
left click once at the beginning of the line. Drag the mouse tothe end location
of the line and left click again. Note that as the mouse is dragged a dashed line
is visible, indicating the current extent of the line object.Left click once on the
end point of the line object to draw another line object starting from the end of
the first; continue as needed. Double left click or single left click and press the
Enter key on the keyboard to terminate the drawing of the nextline.

When using this command in an elevation view or 3D view, if a line object is
drawn that crosses story levels, ETABS immediately breaks the object at the
story levels. For example, if a line object is drawn that has its top at the 4th story
level and it bottom at the 2nd story level, ETABS immediatelybreaks the object
into two objects with the break point at the 3rd story level.

• Create Lines at Regions or at Clicks

The Draw menu> Draw Line Objects> Create Lines in Region or at Clicks
(plan, elev, 3D) command allows the user to draw beam elements at any location
in the model. There are two ways you can draw the columns.
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8 CSI STEEL FRAME DESIGN SEMINAR

You can click on any grid line (in plan view only) and a line object is drawn
on that grid line between the two adjacent intersecting gridlines from the same
coordinate/grid system.

Alternatively, in all views, depress and hold down the left button on your mouse.
While keeping the left button depressed, drag the mouse to “rubber band” a
window around one or more grid line segments. Then release the left mouse
button. Line objects are automatically placed at each grid line segment included
in the “rubber band” window. The term grid line segment in this paragraph
means that portion of a grid line between the two adjacent intersecting grid lines
from the same coordinate/grid system.

• Create Columns at Regions or at Clicks

After you have activated the Draw menu> Draw Line Objects> Create Columns
in Region or at Clicks (plan) command there are two ways you can draw the
columns. They are:

Left click at any location in a plan view to draw a column (vertical line object
below).

Working in plan view, depress and hold down the left button onyour mouse.
Perform the same operation when creating line at regions. Columns (vertical
line objects below) are automatically placed at each grid line intersection of
two grid linesin the same coordinate/grid systemincluded in the “rubber band”
window.

The columns (vertical line objects) extend from the story level that you draw
them on to the story level below, and, of course, also to otherstory levels if you
have the similar stories feature in the ETABS status bar activated.

• Create Secondary Beams at Regions or at Clicks

The Draw menu> Draw Line Objects> Create Secondary Beams in Region or
at Clicks (plan) command allows you to draw typical infill (secondary) beams
for an entire grid line space (beam bay) in a single click. Thegrid line space is
defined by four adjacent intersecting grid lines. If beams are already in the grid
line space, the spacing and extent (length) of the secondarybeams is based on
the existing beams rather than the grid lines. The figure below shows an example
of a grid line space and secondary beams. Note that secondarybeams are not
included on the grid lines.

• Create Braces at Regions or at Clicks

Draw menu> Draw Line Objects> Create Braces in Region or at Clicks Use
this command to quickly draw brace elements in a space bounded by two adja-
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PART I. GENERAL MODELING 9

cent grid lines (from the same coordinate/grid system) and two adjacent story
levels.

Click inside the space created by the intersection of two adjacent grid lines (from
the same coordinate/grid system) and two adjacent story levels.

Alternatively, depress and hold down the left mouse button.While keeping the
left button depressed, drag the mouse to “rubber band” a window around one or
more grid line/story level spaces. Then release the left mouse button. Braces are
automatically placed in each grid line/story level space within the region that is
fully included in the “rubber band” window. The term grid line/story level space
in this paragraph means the space created by the intersection of two adjacent
grid lines (from the same coordinate/grid system) and two adjacent story levels.

• Draw Area Object

To draw an area object using the Draw menu> Draw Area Objects> Draw
Areas (plan, elev, 3D) command, left click once at the first corner point of the
area, drag the mouse to the next corner point and left click, and so on to define
each corner point of the area object. Note that as you drag themouse a dashed
line is visible indicating the current extent of the area object.

When you reach the last corner point of the area object, double left click to finish
the object or single left click and then press the Enter key onthe keyboard.

Area objects drawn using this command must have at least three corner points.
Typically area objects are limited to no more than four corner points; however,
there is no limit on the maximum number of corner points allowed for horizontal
area objects (in the globalX-Y plane).

Since the model was imported from a .DXF file, some of these draw tools will
not be implemented in the construction of this model. The next step is to assign the
correct beam and column section properties to the line elements.

Use the Assign menu> Frame/Line> Frame Section command to assign frame
section properties to line objects. The frame section property can be a previously
defined property or you can define it as part of the assignment process.

The Assign menu> Frame/Line> Frame Section command can be used to

• import sections from pre-defined databases,

• define frame section properties on the basis of their dimensions,

• review and modify section properties, and

• delete section properties.
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10 CSI STEEL FRAME DESIGN SEMINAR

To assign frame sections:

• Select the line objects to which section properties are to be assigned.

• Click the Assign menu> Frame/Line> Frame Section command to bring up
the Assign Frame Properties form.

• On the Assign Frame Properties form, the “Properties” areaof this form lists
the names of all the currently defined frame section properties; ETABS auto-
matically creates this list, which you can use or add to, modify, or delete as
necessary using the two drop-down lists.

• To view or modify a certain section, click on the modify/show section button.
See Figure I.7:

Figure I.7: Beam Section Properties Dialogue Box
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PART I. GENERAL MODELING 11

I.4 Importing/Exporting to/from various BIM Imple-
mentation

Building Information Modeling (BIM) is a buzzword that is becoming more commonly
used by the structural engineering community. BIM implements the concept of storing
all of the information about a building in one single computer model. It allows users to
maintain a database from which project lifecycles can manage. BIM implementations
allow users to create and manipulate construction and fabrication documents with great
ease.

Currently on the market, there are a handful of BIM implementations available.
CSI recognizes the value in such products and as responded accordingly. Over the past
few years, CSI has proactively worked to create interfaces with various BIM imple-
mentations. These interfaces allow users to import and export their Building Informa-
tion Models into and out of ETABS to make use of the state of theart analysis and
design functionality that the structural engineering community has been using with
confidence for the past 30 years. Currently CSI has built interfaces with the following
BIM implementations:

• Autodesk®Revit®Structure (Autodesk)

• Archicad ®(Graphisoft)

• Tekla Structures (Tekla Corporation)

In today’s seminar, we will touch on how ETABS works with these various prod-
ucts. For additional information on the ETABS interfaces with various these third party
BIM products, please contact CSI.

I.5 OpenGL Graphics Option in ETABS
The new viewer in ETABS is a new feature that enables the user to see the model
using OpenGL graphics. In later versions of ETABS, this willbe the default view
used. With the active window displaying a Plan or 3D view, click the View menu
> Create OpenGL View command to display a rendered view of yourmodel in the
Rendered Viewer window.

This Rendered Viewer window has a number of buttons for manipulating the
rendered image. Some of the most useful buttons are explained below:
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PART I. GENERAL MODELING 13

In Figure I.8, you can see how the structure looks using the OpenGL viewer.
When using the OpenGL viewer, the user can create .AVI movie files while moving
through the structure. To do this, press the ‘Start Capturing Scene’ button the toolbar
on the top of the screen. When finished, press the ‘Stop Capturing Scene’ button and
save the .AVI file.

Figure I.8: OpenGL Rendered View

I.6 Slab Meshing Options
NOTE: During analysis, ETABS automatically meshes (divides) area objects that are
assigned deck properties or slab properties with membrane behavior only. If a slab
element is assigned a shell property, you must assign floor auto-meshing options or
manually mesh the slab. Meshing helps distribute loads realistically.

A wall or slab section can have shell, membrane or plate-typebehavior. Shell-
type behavior means that both in-plane membrane stiffness and out-of-plane plate
bending stiffness are provided for the section. Membrane-type behavior means that
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14 CSI STEEL FRAME DESIGN SEMINAR

only in-plane membrane stiffness is provided for the section. Plate-type behavior
means that only out-of-plane plate bending stiffness is provided for the section.

During analysis, ETABS automatically meshes (divides) area objects that are
assigned deck properties or slab properties with membrane behavior only. For this
example, we are using slab type elements; therefore, we mustmesh the slabs manually.
First, select all of the floor elements (from Select> Area Object Type> Floors) and
go to Assign> Shell/Area> Area Object Mesh Options. Click on the Auto Mesh
Objects into Structural Elements button. Then, select the1st three options. These
options are 1) Mesh at beams and other meshing lines 2) Mesh atwall and ramp edges
and finally 3) Mesh at visible grid lines. Meshing helps distribute loads realistically.
In some cases you may not want ETABS to automatically mesh an area object into the
analysis model.

When an element does not frame into the corner point of a shellelement, but
instead frames into the edge of the shell element, no connection exists between the
element and the shell element. ETABS is able to perform the analysis in this fashion.
However, ETABS also has a very powerful feature called an Auto Line Constraint. The
ETABS auto line constraints feature allows you to specify that elements framing into
the edge of a shell element be connected to the shell element.ETABS internally takes
care of connection between the elements by constraining points lying along an edge of
the shell element to move with that edge of the element. This option is located under
the Assign Menu> Shell/Area> Auto Line Constraint. By default, the Auto Line
Constraint feature in ETABS is active (i.e. turned on). You have to flexibility to use
the line constraint on the entire model or specific elements of the model. Additional
information regarding the auto line constraint functionality in ETABS can be found at
the end of this manual in a paper entitled “Mesh Transitioning and Compatibility using
the auto line constraint in ETABS and SAP2000.“

To demonstrate how the different slab meshing options work,let’s take a look at a
small model. In this example, there are 6 individual frame systems, each with different
slab element properties. You will see that certain slab property types distribute load in
different ways.

For this example, the self-weight multiplier in the DEAD load case has been set
to zero. Instead, a 50 psf surface load has been applied to allof the slab elements.
Listed below are the slab property names and definitions:

DECK1: A deck property has been defined. ETABS has built-in default area object
properties for DECK1, a metal deck. Changes can be made to thetype of section,
the geometry, the material, the unit weight of the section. DECK properties
apply load to an area object as a one-way slab spanning in the local 1 direction
of the area object.

1WAYM: A membrane type property has been defined. Membrane-type behavior
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PART I. GENERAL MODELING 15

means that only in-plane membrane stiffness is provided forthe section. Also,
theUse Special One-Way Load Distributioncheckbox has been selected which
means the load applied to area objects with this section property is to be dis-
tributed as a one-way slab spanning in the local 1 direction of the area object.

SLAB6: A 6” slab with a shell type property has been defined. Shell-type behav-
ior means that both in-plane membrane stiffness and out-of-plane plate bending
stiffness are provided for the section.

SLAB6M: A 6” slab with a membrane type property has been defined. For this slab
element, the Special One-Way Load Distribution boxhas notbeen checked.

The two structures on the right side both have SLAB6 sectionsassigned to them.
The only difference is that these slabs have been meshed. To do this, select the top
right slab element, go to Edit> Mesh Areas> select the Mesh Quads/Triangles into
2 by 2 sections. This will break the slabs into 4 total pieces.Next, select the bottom
right slab element and repeat this procedure but this time enter a4 × 4 mesh. Please
refer to Figure I.9.

Figure I.9: 3D View — Meshing Example

After you run the analysis, go to Display> Show Member Forces/Stresses Dia-
gram> Frame/Pier forces. From the pull down menu, select the DEAD load case and
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16 CSI STEEL FRAME DESIGN SEMINAR

the Moment 3-3 component. The moments for all of the frame systems will be shown
graphically. Please refer to Figure I.10:

Figure I.10: 3D View — Moment Diagram

As you can see, the 1WAYM and DECK1 properties behaved very similarly.
The 1WAYM slab was assigned a membrane property, so it was automatically meshed
internally. The one-way load distribution spanning in the local 1 direction is clearly
shown on the left 2 frame systems. There is no moment on the topand bottom frame
elements. SLAB6 and SLAB6M behaved very differently. SLAB6was assigned a
shell property type, so it wasnot meshed internally. The loads were applied to the four
corners of the slab; therefore no moments are shown on the frame elements. SLAB6M
was assigned a membrane property type, which was meshed automatically. Loads
were distributed to the frame elements in both directions. The frame systems on the
right hand side both have SLAB6 properties assigned to them.The difference is that
one slab was meshed more densely than the other. Meshing of slab elements allows
loads to be distributed at the mesh points. As shown in FigureI.10, if the mesh is
more refined, there will be more points of load application. That is why the moment
diagrams are different for the frames on the right hand side.
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PART II

Static and Dynamic Loading of Diaphragms

II.1 Rigid and Semi-Rigid Floor Diaphragms

Assigning a diaphragm to an area object provides a diaphragmconstraint to all of the
corner points of the area object and to any additional point objects that are enclosed
within the boundaries of the area object. This includes any points (joints) that are
created as a result of automatic area object meshing.

Important : Diaphragms can be horizontal only. Thus diaphragm assignments
are not applicable to wall-type and ramp-type area objects.They are applicable only
to floor type area objects and to null-type area objects that happen to be in a horizontal
plane.

In this model, we will assign semi-rigid diaphragms to all floor elements. This
is a new option in ETABS. First, select all floor elements, andunder the Assign>
Shell/Area> Diaphragms option, click the Add New Diaphragm button to access the
Diaphragm Data form. Use the default name suggested in theDiaphragmedit box, or
enter another name.

Specify the rigidity of the diaphragm by choosing theRigidor Semi Rigidoption.
These options affect only the analysis of the model. If the rigid option is selected, a
fully rigid diaphragm is assumed. If the semi rigid option isselected, the in-plane
rigidity of the diaphragm comes from the stiffness of the objects that are part of the
diaphragm. Select the Semi-Rigid option and click OK. You will now see the semi-
rigid diaphragm has been assigned the all floors of the structure. The point where all
of the lines of the diaphragm intersect is the center of mass.See Figure II.1:

17
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18 CSI STEEL FRAME DESIGN SEMINAR

Figure II.1: Semi-Rigid Diaphragm Assignment

II.2 IBC 2003 Seismic Loads
To define earthquake and wind loads to the structure, you mustgo to Define> Static
Load Cases. You can see that there are two default load cases already defined, DEAD
and LIVE. Type EQX in the LOAD box, select a QUAKE type case, and then select
the IBC 2003 seismic code from the pull down menu. Click Add New Load followed
by the Modify Lateral Load button. The menu shown in Figure II.2 will pop up.

Choose to specify theX or Y direction of the seismic loading, or to specify the
direction with a percentage of eccentricity that is applicable to all diaphragms. Use the
% Eccentricityedit box to specify a value for eccentricity. For this example, we will
select to apply the loads in theX-dir.

Choose theTop Story andBottom Story to specify the elevation range over
which the automatic static lateral loads are to be calculated. By default the bottom
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PART II. STATIC AND DYNAMIC LOADING OF DIAPHRAGMS 19

Figure II.2: IBC 2003 Seismic Load Definition

story is the base of the building and the top story is the uppermost level of the building.

In most instances, specify the top story as the upper-most level in the building,
typically the roof. The bottom level would typically be the base level. However, for
this example, the building has several below-grade levels,and the seismic loads are
assumed to be transferred to the ground at ground level, so itis best to specify the
bottom story to be the7th Story (level of the ground). Enter the Response Factor,
Seismic Group and Seismic Coefficients as shown in Figure II.2.

IBC2006 Seismic and Wind loads will be included in the next version of
ETABS.

II.3 Response Spectra Load Application
In this example, we are interested in using a pre-defined response spectrum function
from the ETABS database. Go to Define> Response Spectrum Function> Select the
IBC 2003 Spectrum from the pull-down menu. As shown, in Figure II.3, the user can
change the Design Spectral response for the curve. The period and acceleration values
are shown on the right hand side of the menu. These values are associated with the
IBC2003 code and cannot be edited. To enter your own period and acceleration values,
you must select the “Add user Spectrum” option from the pull-down menu.
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Figure II.3: Response Spectrum Function Definition

Next, we define the Response Spectrum case data. Go to the Define Menu>
Response Spectrum Cases> Add New Spectrum. There are many options available
including Structure and Function Damping, Modal and Directional Combination, Input
Response Spectra and Eccentricities. It is important that you understand the structural
and function damping item. This item specifies modal dampingthat is present for all
modes in the response spectrum analysis. Also, ETABS assumes that the response
spectrum functions specified for the response spectrum caseare all specified for this
particular damping ratio.

For example if you specify 2% damping for this term, there is 2% modal damp-
ing in all modes for the response spectrum analysisand the response spectrum func-
tions specified for this response spectrum case are for 2% damping.

The user must specify the method ETABS uses to combine modal responses in
the response spectrum analysis and also define a damping value. The following options
are available for modal combinations:

CQC: This is the Complete Quadratic Combination method described by Wilson, Ki-
ureghian and Bayo (1981). This modal combination techniquetakes into ac-
count the statistical coupling between closely spaced modes caused by modal
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damping. Increasing the modal damping increases the coupling between closely
spaced modes. If the modal damping is 0 for all modes, then theCQC method
degenerates to the SRSS method.

SRSS: This is the Square Root of the Sum of the Squares method. This modal com-
bination technique does not take into account any coupling of modes as do the
CQC and GMC methods.

ABS: This is the Absolute method. This modal combination technique simply com-
bines the modal results by taking the sum of their absolute values. This method
is usually over-conservative.

GMC: This is the General Modal Combination method that is also known as the
Gupta method. This method is the same as the complete modal combination
procedure described in Equation 3.31 in Gupta (1990). The GMC method takes
into account the statistical coupling between closely spaced modes similar to
the CQC method, and it also includes the correlation betweenmodes with rigid-
response content.

We are interested in assigning the response spectrum function loading (SPEC1)
in the X-direction. Enter a scale factor of 386.4 if you are using k-in units. The CQC
modal combination was selected as well as the SRSS directional combination. Please
see Figure II.4:

II.4 Time History Load Application
In this example, we are interested in defining a pre-defined time history function from
a text file. Go to Define> Time History Function> Add Function from File. Click
the Browse button and select the time history text file. The record we have selected
is the 1940 El Centro earthquake record. This text file contains time and acceleration
values for the specified earthquake. You can view time history graph by clicking on
the Display Graph button. Fill in the Function File information as in Figure II.5:

Next, we define the Time History case data. Go to Define> Time History Cases
> Add New History. There are many options available includingAnalysis Type, Num-
ber of Output Time Steps and Output Time Step Size.The outputtime step size is the
time in seconds between each of the equally spaced output time steps. Do not confuse
this with the time step size in your input time history function. The number of output
time step size can be different from the input time step size in your input time history
function. The number of output time steps multiplied by the output time step size is
equal to the length of time over which output results are reported.

We are interested in assigning the time history acceleration in the x-direction.
The time history is a 12-second record, so enter 6000 time steps and time step size of
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Figure II.4: Response Spectrum Case Function Definition

0.002 seconds. Enter a scale factor of 386.4 if you are using k-in units. Please see
Figure II.6:

II.5 Use of Special Seismic Load Effects
ETABS can automatically calculate the Rho factor, which is areliability factor based
on system redundancy. Go to the Define Menu> Special Seismic Load Effects to enter
special seismic load data. There are many options in this menu, including selection of
Rho factor, IBC2000 seismic design category, and later force resisting system type.

If you select theInclude Special Seismic Design Dataoption, the program cal-
culated (or user defined) Rho factor and the user defined DL Multiplier areautomati-
cally applied to program default design load combinations for American codes (ACI,
AISC, UBC) that include contributions from earthquake loads. Earthquake loads in
this case are assumed to be all static loads of type Quake, andall response spectrum
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Figure II.5: Time History Function Definition
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Figure II.6: Time History Case Definition
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PART II. STATIC AND DYNAMIC LOADING OF DIAPHRAGMS 25

and time history cases. If theDo not Include Special Seismic Design Dataoption
is selected, the Rho factor and the DL Multiplier are not applied to any design load
combinations.

Under the Rho Factor (Reliability Factor based on Redundancy) section, the
Program Calculated ETABS calculates the Rho factor in accordance with Section 1617
of the 2000 International Building Code. The automatic calculation of the Rho factor
depends on the floor area. ETABS calculates the floor area at each story level by
summing the areas of the floor-type area objects at each storylevel. If no floor type
area objects exist at a story level, that story level is ignored when calculating Rho. If
no floor type area objects exist atany story level, and ETABS is to calculate the Rho
factor, Rho is assumed to be equal to 1.5.

Important Note : The calculation of the Rho factor also depends on the ratio of
the design story shear resisted by the most heavily loaded element in a story divided
by the total story shear. This ratio is designatedrmax. The value ofrmax can only be
calculated if there is lateral load in the model. The Rho factor can only be calculated
if rmax is nonzero.Thus, the Rho factor is only calculated when there is lateralload
present in the model.Refer to Figure II.7:

Figure II.7: Special Seismic Data for Design
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II.6 Auto-permutation of Wind Directions and Eccen-
tricities

Next, we will define the wind load cases to the model. Perform the same operation as
discussed earlier to define a wind load case. This time we willapply a wind load in
the Y-direction. Give the load case a name of WY, select a WINDload type and select
the ASCE 7-02 code from the pull down menu. Click the Modify Lateral Load button
to bring up the menu shown in Figure II.8:

Figure II.8: ASCE 7-02 Wind Load Definition

We have defined rigid diaphragms to this model, so select the ‘Exposure from
Extents of Rigid Diaphragms’ option. The width of the diaphragm is calculated by
the ETABS. To apply the wind load in the Y-direction, enter 90degrees for the wind
direction angle. The windward and leeward coefficients are defined as 0.8 and 0.5
respectively.

A new feature in ETABS allows the user to define one wind load case and the
program will automatically create all of the remaining windload cases. The ASCE 7-
02 wind code must be used for this feature to be activated. Thee1 and e2 values
changes for each subsequent wind load case based on Figure 6.9 as well as the wind
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direction angles in the ASCE 7-02 code. A total of 12 different wind load cases will
be defined. Enter all of the remaining Wind Coefficients shownin Figure II.8.
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PART III

Steel Frame Design
Using ANSI/AISC 341-05 Steel Code)

III.1 Example 1
This Simple Beam example is intended to demonstrate the ETABS AISC 2005 steel
design code features. The first example below shows the program checks for various
flexure limit states. The Example 1 definitions are describedin Figure III.1:

4 spaces @ 12 ft = 48’-0”

111k 111k 111k

Figure III.1: Example 1

The section properties for W30X148 beam shown in Figure III.2:

Reference is made to ASCE 360-05 Specifications, Chapter F, for flexural de-
sign. Chapter F is divided into sections F1 through F11 whichare referenced in this
For clarity, the SAP2000 and ETABS capabilities are discussed with reference to the
subject sections. The ASCE 360-05 Table F1.1 is presented inFigure III.3 and includes
the subjects sections.

29
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Figure III.2: W30X148 Section Properties

III.1.1 Check for Compact Section Requirements

Check for compact section requirements:

bf

2tf
=

10.5

2(1.18)
= 4.45 ≤ λp = 0.38

√

E

Fy

= 9.15 (III.1)

h

tw
=

26.5

0.65
= 40.8 < λp = 3.76

√

E

Fy

= 90.55 (III.2)

Sinceλ is less thenλp for the flange and web the section is compact. The limit state
for local buckling will not control.

III.1.2 Check The Limit State For Flexural Yielding

Mu ≤ φMn (in LRFD) andM ≤ Mn/Ωb in (ASD)

Mn = FyZx,

Mn = 50ksiX500in3=25, 000kip− in (III.3)

Check for lateral torsional buckling whereLb is the unbraced length,Lp andLr

are limiting lengths:
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Figure III.3: ASCE 360-05, Table F1.1
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a. WhenLb ≤ Lp

Mn = Mp (ASCE F2-1)

b. WhenLp < Lb ≤ Lr

Mn = Cb

[

Mp − (Mp − 0.7FyS33)

(

Lb − Lp

Lr − Lp

)]

≤ Mp (ASCE F2-2)

c. WhenLb > Lr

Mn = CbS33
π2E

(

Lb

rts

)2

√

√

√

√

1 + 0.078
Jc

Sxho

(

Lb

rts

)2 ≤ Mp (ASCE F2-3,4)

Where,

Lp = 1.76ry

√

E

Fy

(ASCE F2-5)

Lr = 1.95rts

E

0.7Fy

√

Jc

S33ho

√

√

√

√

1 +

√

1 + 6.76

(

0.7Fy

E

S33ho

Jc

)2

(ASCE F2-6)

For this example,

1. Lb = 12ft(144in)

2. Lp = 1.76ry

√

E
Fy

, which gives,Lp = 96.6

3. Lr = 1.95rts
E

0.7Fy

√

Jc
S33ho

√

1 +

√

1 + 6.76
(

0.7Fy

E
S33ho

Jc

)2

where,

rts =
bf

√

12
(

1 + 1
6

htw

bf tf

)

=
10.5

√

12
(

1 + 1
6

26.5(0.65)
10.5(1.18)

)

= 2.73in (III.4)

J = 14.5in4 (from section property data) (III.5)

ho = 30.7 − 1.18 = 29.52in (III.6)
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c = 1.0 (for doubly symmetric I-shape) (III.7)

Lr = 1.95(2.73)
29500

0.7(50)

√

14.1(1.0)

436(29.52)

√

√

√

√

1 +

√

1 + 6.76

(

0.7(50)

29500

436(14.1)

14.1(1.0)

)2

(III.8)

Lr = 293in (III.9)

SinceLp < Lb ≤ Lr,

Mn = Cb

[

25000−

(

25000− 0.7(50)436

(

144 − 96.6

293 − 96.6

))]

(ASCE F2-6)

Mn = Cb(21, 317)kip− in (III.10)

where,

Cb =
12.5Mmax

2.5Mmax + 3MA + 4MB + 3MC

Rm ≤ 3.0 (ASCE F1-1)

where:

Mmax is the absolute value of the maximum moment in the unbraced segment
and MA, MB and MC are the absolute values of the moment at quarter, half,
and three-quarter points of the unbraced segment, respectively. Rmis the cross-
section monosymmetry parameter that is given by:

1.0 = for doubly symmetric sections

1.0 = for singly symmetric members with single curvature

0.5 + 2(
Iyc

Iy
)2 for reverse bending

Cb should be taken as 1.0 for cantilevers. However, the SAP2000 and ETABS
are unable to detect whether the member is a cantilever. The user should over-
write Cb for cantilevers. The program also defaults Cb to 1.0if the minor
un-braced length, l22, is redefined to be more than the lengthof the member
by either the user or the program, i.e., if the unbraced length is longer than
the member length. The user can overwrite the value of Cb for any member.
The nominal bending strength depends on the following criteria: the geometric
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shape of the cross-section; the axis of bending; the compactness of the section;
and a slenderness parameter for lateral-torsional buckling. The nominal bending
strength is the minimum value obtained according to the limit states of yielding,
lateral-torsional buckling, flange local buckling, and weblocal buckling.

Reference is made to ASCE 360-05 Specifications, Chapter F, for flexural de-
sign. Chapter F is divided into sections F1 through F11 whichare referenced in
this For clarity, the SAP2000 and ETABS capabilities are discussed with refer-
ence to the subject sections. The ASCE 360-05 Table F1.1 is presented below
and includes the subjects sections

For this example:

15187k-in

7823k-in

22554k-in

1 2 3 4

Figure III.4: Example 2

• Segment 1:

Cb =
12.5Mmax

2.5Mmax + 3MA + 4MB + 3MC

Rm ≤ 3.0 (III.11)

Cb =
12.5(15187)

2.5(15187) + 3(3797) + 4(7594) + 3(11390)
1.0 ≤ 3.0 (III.12)

Cb = 1.67 (III.13)

• Segment 2:

Cb =
12.5(15187)

2.5(15187) + 3(13346) + 4(11505) + 3(9664)
1.0 ≤ 3.0 (III.14)

Cb = 1.24 (III.15)
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• Segment 3:

Cb =
12.5(22554)

2.5(22554) + 3(229) + 4(7365) + 3(14960)
1.0 ≤ 3.0 (III.16)

Cb = 2.15 (III.17)

• Segment 4:

Cb =
12.5(22554)

2.5(22554) + 3(5638) + 4(11277) + 3(16916)
1.0 ≤ 3.0 (III.18)

Cb = 1.67 (III.19)

For this example,Cb = 2.15

Mn = 2.15(21, 317) = 45, 831kip− in > Mp = 25, 000kip− in (III.20)

therefore,

Mn = Mp = 25, 000kip− in (III.21)

III.1.3 Shear Check

SAP2000 and ETABS design for shear without consideration ofthe post-bucklingten-
sion field action. The design equations for shear are as follows:

Vn = 0.6FyAwCv

Where

Vu ≤ φvVn (in LRFD) andV ≤ Vn/Ωv in (ASD)

And,

Vu= factored applied shear force

V= service(un-factored) applied shear force

Aw = area of web

φv = 1.00 (for LRFD)

Ωv = 1.50 (for ASD)
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CV = shear reduction factor

1. Forh/tw ≤ 1.10
√

kvE
Fy

Cv = 1.0 (ASCE G2-3)

2. For1.10
√

kvE/Fy < h/tw ≤ 1.10
√

kvE/Fy

Cv =
1.10

√

kvE/Fy

h/tw
(ASCE G2-4)

3. Forh/tw > 1.37
√

kvE/Fy

Cv =
1.51Ekv

(h/tw)2Fy

(ASCE G2-5)

For Example 1, the maximum shear,Vu = 211.4kips.

h/tw ≤ 1.10

√

kvE

Fy

wherekv = 5.0 whenh/tw < 260 (III.22)

26.5/0.65 = 40.8 ≤ 53.9 therefore,Cv = 1.0 (III.23)

Vn = 0.6FyAwCv = 0.6(50)0.65(1.0) = 598.65kips (III.24)

ETABS reports the demand/capacity ratio as,

Vu/φVn = 211.3/598.65 = 0.353 (III.25)

III.2 Example 2
Using the same span and loading as defined for Example 1, the demand/capacity ratios
are calculated for a built-up section in lieu of a wide flange section. The built-up
section is defined in Figure III.5:

III.2.1 Check for Compact Section Requirements

bftop

2tf
=

12

2(1.5)
= 4.00 ≤ λp = 0.38

√

E

Fy

= 9.15 (III.26)
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Figure III.5: Built-Up Section Properties
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bfbot

2tf
=

9

2(2.0)
= 2.25 ≤ λp = 0.38

√

E

Fy

= 9.15 (III.27)

h

tw
=

28.0

0.25
= 112 > λp =

hc

hp

√

E
Fy

(

0.54
Mp

My
− 0.09

)2 = 94.4 (III.28)

h

tw
=

28.0

0.25
= 112 < λr = 5.70

√

E

Fy

(III.29)

Sinceλ is greater thanλp for the web, the section is non-compact. The limit
state for local buckling will may control.

III.2.2 Check Limit State of Yielding

For the maximum negative moment causing compression in the bottom flange,Mu ≤

φMn, and,Mn = RpcFyS33c

where,Rpc is the web plastification factor given as,

Rpc =

[

Mp

Myc

−

(

Mp

Myc
− 1

)(

λ − λpw

λrw − λpw

)]

<
Mp

Myc

(III.30)

where,

Myc = Fy(Sxbot
) = 26, 525kip− in (III.31)

Mp = Zxbot
(Fy) = 50(584.5) = 29, 225kip− in (III.32)

thus,Rpc = 1.06 (III.33)

Mp = RpcZxbot
(Fy) = 1.06(50)(530.5) = 29, 225kip− in (III.34)

For the maximum negative moment causing tension in the top flange, the section
modulus,Stop > Sbot, thereforeSxtension

> Sxcomp
, and tension yielding will not

control.
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III.2.3 Check Lateral Torsional Buckling

For this example,

• Lb = 12ft(144in)

• Lp = 1.76ry

√

E
Fy

, which gives,1.76(2.80)
√

29500
50 = 118.7in

• Lr = 1.95rts
E

0.7Fy

√

Jc
S33ho

√

1 +

√

1 + 6.76
(

0.7Fy

E
S33ho

Jc

)2

where

rts,top =
bf , top

√

12
(

1 + 1
6

htw

bf tf

)

=
12

√

12
(

1 + 1
6

28(0.25)
12(1.5)

)

= 3.35in (III.35)

rts,bot =
bf , bot

√

12
(

1 + 1
6

htw

bf tf

)

=
9

√

12
(

1 + 1
6

28(0.25)
9(2.0)

)

= 2.52in (III.36)

J = 37.65in4 (from section property data) (III.37)

ho = 31.5 − 1.0 − 0.75 = 29.95in (III.38)

c = 1.0 (III.39)

Lr, top = 1.95(3.35)
29500

0.7(50)

√

37.65(1.0)

540.3(29.75)

√

√

√

√

1 +

√

1 + 6.76

(

0.7(50)

29500

540.3(29.55)

37.65(1.0)

)2

(III.40)

Lr, top = 433in (III.41)

Lr, bot = 1.95(2.52)
29500

0.7(50)

√

37.65(1.0)

540.3(29.75)

√

√

√

√

1 +

√

1 + 6.76

(

0.7(50)

29500

540.3(29.55)

37.65(1.0)

)2

(III.42)
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Lr, bot = 326in (III.43)

SinceLp < Lb ≤ Lr,

•

Mn =

[

RpcMyc − (RpcMyc − FLSxc)

(

λ − λp

λr − λp

)]

(ASCE F3-1)

where,

FL = 0.7Fyfor
Sxt

Sxc

≥ 0.7 (III.44)

Rpc =

[

Mp

Myc

−

(

Mp

Myc

− 1

)(

λ − λpw

λrw − λpw

)]

≤
Mp

Myc

(III.45)

Myc = FySx,top = 27, 015kip− in (III.46)

Mp = 50(584.5) = 29, 225kip− in (III.47)

• Segment 1:

Cb =
12.5Mmax

2.5Mmax + 3MA + 4MB + 3MC

Rm ≤ 3.0 (III.48)

Cb = 1.67 (See Example 1) (III.49)

Mn =

[

RpcMyc − (RpcMyc − FLSxc)

(

λ − λp

λr − λp

)]

(III.50)

Mn = Cb

[

1.06(27, 015)− (1.06(27015)− 0.7(50)(540.3))

(

144 − 118.7

433 − 118.7

)]
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(III.51)

Mn = 46, 515k− in ,but ,Mn ≤ RpcMyc = 1.06(50)540.3 = 28, 635k − in

(III.52)

Mn = 28, 635k − in (III.53)

• Segment 2:

Cb = 1.24 See Example 1 (III.54)

Mn = Cp

[

RpcMyc − (RpcMyc − FLSxc)

(

λ − λp

λr − λp

)]

(III.55)

Mn = 1.24

[

1.06(27, 015)− (1.06(27015)− 0.7(50)(540.3))

(

144 − 118.7

433 − 118.7

)]

(III.56)

Mn = 1.24(27, 853) = 34, 538k− in ,but ,Mn ≤ RpcMyc = 28, 635k − in

(III.57)

• Segment 3:

Cb =
12.5(22554)

2.5(22554) + 3(229) + 4(7365) + 3(14960)
Rm (III.58)

Cb = 2.15Rm (III.59)

where,

Rm = 0.5 + 2

(

Iyc

Iy

)2

= 0.5 + 2

(

2(9)3/12

337.5

)2

= 0.7592 (III.60)

thus,

Cb = 2.15(0.7592) = 1.62 (III.61)
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Myc = 50(530.5) = 26, 525k − in (III.62)

Mn = 1.62

[

1.06(26, 525)− (1.06(26, 525)− 0.7(50)(530.5))(
144− 118.7

326− 118.7
)

]

(III.63)

Mn = 43, 660k − in ,but ,Mn ≤ RpcMyc = 28, 611k − in (III.64)

• Segment 4:

Cb =
12.5(22554)

2.5(22554) + 3(5638) + 4(11277) + 3(16916)
1.0 (III.65)

Cb = 1.67 (III.66)

Mn = 1.67[1.06(26, 525)− (1.06(26, 525)−0.7(50)(530.5))(
144− 118.7

326− 118.7
)]]

(III.67)

Mn = 45, 008k − in ,but ,Mn ≤ RpcMyc = 28, 611k − in (III.68)

III.2.4 Shear Check

For Example 2, the maximum shear,Vu = 211.4kips.

1. Forh/tw ≤ 1.10
√

kvE
Fy

Cv = 1.0 (ASCE G2-3)

2. For1.10
√

kvE/Fy < h/tw ≤ 1.10
√

kvE/Fy

Cv =
1.10

√

kvE/Fy

h/tw
(ASCE G2-4)

3. Forh/tw > 1.37
√

kvE/Fy

Cv =
1.51Ekv

(h/tw)2Fy

(III.69)
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Sinceh/tw = 28.0/0.25 = 112, kv = 5.0, and,

Cv =
1.51Ekv

(h/tw)2Fy

=
1.51(29500)5.0

(112)250
(III.70)

Cv = 0.349 (III.71)

Vn = 0.6FyAwCv = 0.6(50)0.25(31.5)(0.349) = 82.45kips (III.72)

ETABS reports the demand/capacity ratio as,

Vu/φVn = 211.3/82.45 = 2.56 (III.73)

III.3 Example 3

214 kips

350k

350k

Figure III.6: Example 3

The beam/column above is to be designed for the dead loads shown. The member
spans a total of 40 feet with a midspan load of 214 kips and an axial load of 350 kips.
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For this example, the member is laterally braced at midspan.The demand/capacity
ratio for the subject member is found as follows:

The member section properties are:

Figure III.7: Built-Up Section Properties

The warping constant,Cw = Iyh2/4 = 456, 500in6

III.3.1 Check Flexural Buckling

The limit state for flexural buckling is checked as,

Pn = FcrAg

Where,

Pu ≤ φcPn (in LRFD) andP ≤ Pn/Ωc in (ASD)

And,

Pu= factored applied compressive force

P= service(un-factored) applied compressive force

Ag = gross area of member

φc = 0.90 (for LRFD)

Ωv = 1.67 (for ASD)

Fcr = flexural buckling stress, determined as shown below,

a. WhenkL
r

≤ 4.71
√

E
Fy

Fcr = [0.658
Fy
Fe ]Fy (ASCE E3-2)
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b. WhenkL
r

> 4.71
√

E
Fy

Fcr = 0.877Fe (ASCE E3-3)

where,Fe = elastic critical buckling stress,

Fe =
π2E

(KL
r

)2
(ASCE E3-4)

For this example,

kl/rx = 1.0(40x12)/15.74 = 30.5 (III.74)

kl/ry = 1.0(20x12)/4.46 = 53.8—–controls (III.75)

Sincekl/ry = 53.8 < 4.71
√

E
Fy

= 113, use,Fcr = [0.658
Fy
Fe ]Fy

Fe =
π2E

(KL
r

)2
= π229500/(53.8)2 = 99ksi (III.76)

Fcr = [0.658
Fy
Fe ]Fy = [0.658

50

99 ]50 = 40.47ksi (III.77)

Pu = φFcrAg = .9(40.74)(67.0) = 2440kips (III.78)

III.3.2 Check Torsional and Flexural-Torsional Buckling

Fcr, is determined using ASCE 360-05 E3-2 and E3-3 andFe, is determined as fol-
lows:

For Doubly Symmetric members

Fe =

[

π2ECw

(KzL)2
+ GJ

] (

1

I22 + I33

)

(ASCE E4-4)
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Fe =

[

π229500(456, 500)

(1.0(40)12)2
+ (11, 200(18.4))

](

1

16609 + 1334

)

= 30.7ksi

(III.79)

Pu = φFcrAg = .9(30.7)(67.0) = 1848kips, Pu is controlled by Flexural-Torsional Buckling

(III.80)

III.3.3 Check Limits States for Flexure

bf

2tf
=

20

2(1.0)
= 10.0, should be≤ λp = 0.38

√

E

Fy

= 9.15 (III.81)

Therefore, local buckling can occur andMp must be reduced.

λr = 0.95

√

kcE

FL

= 0.95

√

0.577(29500)

35
= 20.95 (III.82)

Where,

kc = 4/
√

h/tw = 4/
√

36/0.75 = .577 (III.83)

FL = 0.7Fy = 0.7(50) = 35.0ksi (III.84)

Therefore, local buckling can occur andMp must be reduced.

h

tw
=

36.0

0.75
= 48.0 < λp = 3.76

√

(E/Fy = 90 (III.85)

Mn =

[

RpcMyc − (RpcMyc − FLSxc)

(

λ − λp

λr − λp

)]

(III.86)
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where,

Mp = 50(983) = 49, 150k − in (III.87)

Myc = 50(874) = 43, 700k − in (III.88)

Rpc = Mp/Myc =
49, 150

43, 700
= 1.12, is the web plastification factor (III.89)

Myc = Fy(Sx) = 50(874)43, 700kip− in (III.90)

Mp = Zxbot
(Fy) = 50(983) = 49, 152kip− in (III.91)

Thus,

Mn =

[

1.12(43, 700)− (1.12(43, 700)− 0.7(50)(874))

(

10.0 − 9.5

20.95− 9.5

)]

(III.92)

Mn = 48, 142k − in (III.93)

III.3.4 Combined Loads

Pr

Pc

+
8

9

(

Mrx

Mcx

+
Mry

Mcy

)

≤ 1.0 (III.94)

490

1848
+

8

9

(

35, 952

φ48, 142

)

= 1.003 (III.95)
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PART IV

Detailing of Concrete Foundations

IV.1 CSI Detailer Add-On Module
CSiDETAILER is a user friendly detailing and drawing program for preparing en-
gineering drawings of concrete and steel structures using analysis and design output
from ETABS and SAFE. The program performs the entire detailing operation using
preferences that may be set by the user and the relevant requirements of the building
codes and detailing standards. Additional parameters can be specified to customize the
output to meet other requirements.

Note: CSiDETAILER generates drawings using data from ETABS and SAFE.
The user is responsible for thoroughly examining the CSiDETAILER-generated draw-
ings and, if necessary, refining them. To facilitate refinement and editing, various tools
are provided in CSiDETAILER. Moreover the program can generate DXF and DWG
files of the drawings. Those drawings then can be opened and edited using AutoCAD,
or other CAD software. CSiDETAILER prepares detailed engineering drawings in ac-
cordance with detailing codes, such as ACI 315-99, or by preferences set by the user.
Those preferences may comply with building codes as well as be customized to meet
additional requirements.

IV.2 Drawing and Detailing of Complex Slabs
As indicated previously, CSiDETAILER generates detailed engineering drawing based
on the output from ETABS and SAFE. Thus, to begin the detailing process, prepare
a structural model. The concrete outlines and the layouts ofthe structural members

49
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50 CSI STEEL FRAME DESIGN SEMINAR

can be viewed at any time using theDetailing > Start Detailing command. However,
to obtain view, the reinforcing details of a member, the analysis and design has to be
carried out first. Refer to Figure IV.1 to see the initial setup screen for CSiDETAILER.

Figure IV.1: CSiDETAILER Setup

In this menu, the user can define all of the detailing options.The Setup drawing
button allows the user to specify the drawing units (e.g., ANSI Engineering, ANSI
Architecture, standard), drawing size, drawing scale, text symbol and gap size, mar-
gins, and title block. If the drawing size or scales have beenchanged, click the Match
Default Scales to Drawing Size button to quickly and accurately adjust the options
related to text and symbol size for consistent output. The Specify codes, units, and
dimensioning button specify standards, dimension units, tolerances, material quantity
units, and formatting.

Specify the parameters for detailing objects. The Detailing Preferences button
accesses theDetailing Preferencesform where the user can make changes to column,
wall, footing and mat preferences. Use the form to assign detailing options for the
various design objects.
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IV.3 Creation of Slabs and Sections
Set various preferences using this form (Step 3) and clickStart Detailing. As the
program details the model, progress will be shown on theDetailing Statusform. When
the detailing is complete, a “Detailing Complete” message will be displayed on the
form. The right panel of the screen will show the list (collapsible list) of all items
detailed for the model. Scroll the generated report to view errors and warnings reported
by the program. Once finished click theShow Drawingsbutton and the program will
automatically generate typical drawings and add them to theproject file. Browse the
Drawings by clicking on the drawing title on theDrawing Explorerpanel. When
expanded, each item on the panel will show the names of views available on each
drawing. See Figure IV.2:

Figure IV.2: CSiDETAILER Beam Framing Plan

CSiDETAILER provides extensible and easy-to-use tools formanaging views
and drawings. With the comprehensible interface of the program, users can easily add
new drawings to their projects, add, move, delete, and arrange views on drawings, and
save views and drawings to a library. See Figure IV.3 for a beam reinforcing example.



i

i

“EtabsSteelSeminar” — 2006/9/18 — 15:25 — page 52 — #60
i

i

i

i

i

i
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Figure IV.3: CSiDETAILER Beam Reinforcing Section

IV.4 Reinforcing Details and Bar Schedules
Reinforcement can be modified graphically using theCheck and Edit Reinforcement
form. Click theEdit > Check and Edit Reinforcement> Mat Reinforcementcom-
mand to display theCheck and Edit Reinforcementform shown in Figure IV.4.

Select the design strip for which reinforcement is to be modified by clicking on
it. Use the various zooming and panning options to facilitate the selection process.

When the strip is selected, the strip detail area is updated showing the selected
strip with all provided reinforcements, rebar calls and extents. Graphical illustrations
of the required, provided and minimum reinforcement profiles are also displayed along
the length of the strip.

Under the Tables> Rebar Schedule, you see rebar information, including bar
marks, bar sizes, horizontal dimensions, cut lengths, total lengths of each bar type and
their shapes, codes and graphical displays of all the bars for the detailed objects. The
tables can be viewed and verified against the drawings but they cannot be edited. See
Figure IV.5 to see this Table:
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Figure IV.4: CSiDETAILER Check/Edit Reinforcement

Figure IV.5: CSiDETAILER Rebar Schedule
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PART V

Creation of Output Reports for Submittal

V.1 Detailed Steel Beam Output
When modeling large structures, it is very easy to for ETABS to create an enormous
amount of output. ETABS has a feature that enables the user toselect what specific
output they need. The user can also select the elements (frames, walls, floor, etc) for
which output to print.

We are interested in printing steel frame design output for columns at the base of
the structure. First, select a few columns for which you wishto see design output. Go
to Print Tables> Steel Frame Design> click on the Output Summary and Selection
Only options and click OK. The information shown in Figure V.1 will be printed for
each column selected. You can organize output reports for submittal by selecting all
controlling concrete sections and printing design output information for each of them.

Click on the Output Summary, Detailed Output, and Selectiononly buttons. This
will print only the design output for the selected shear walls as shown in Figure V.1.

V.2 Added Design Output to Database
Another way to extract output data from ETABS is to use one of the export options.
Again, select the shear walls that you want information for and Go to Export> Save
Input/Output as Access Database File. Check the check box associated with an item to
include that item in the export. Expand the tree associated with a table type by clicking
on the plus (+) symbol that precedes the table type name. Continue expanding the tree
until the table appears. Make selections as shown in Figure V.2 and then click the OK
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Figure V.1: Print Steel Design Tables

button. You will be asked to give the database a filename.

To open the Access Database file, double-click on the file in the saved location.
Once the file has been opened, double-click on the Pier DesignForces Table. A spread-
sheet will appear that displays all of the design forces (P, V2, V3, M2, M3, etc) in a
tidy format. See Figure V.3:

Another way to access output from ETABS is to Click the File menu > Print
Tables> Analysis Output command to access the Print Output Tables form. Use the
check boxes, drop-down list, edit box, and buttons on the form to specify the type of
analysis output to be printed, the sort order, and if data is printed to file, the path and
filename for storing the file.If some objects are selected before executing the File menu
> Print Tables> Output command, the printed output will be for the selected objects
only. The Type of Analysis Results check boxes are used to select (or deselect) the type
of data to be included in the printed output. If an item is “grayed out” and the check box
is unavailable, the item is not included in the model. The Select Loads button accesses
the Select Output form. Click on a load to select or deselect it. Click the Clear All
button to deselect all previously selected loads. The Select Cuts buttons chooses the
section cuts to be included in the printed output. Click on a section cut name to select
or deselect it. Click the Clear All button to deselect all previously selected section cuts.
The Print to File checkbox prints the specified data to a text file. Use the File Name
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Figure V.2: Export Output to Access Database File

Figure V.3: Access Database Output File
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edit box and the Browse button to specify the path and filenamefor storing the .txt file.
The Selection Only check box is enabled if point, line or areaobjects were selected
before the File menu> Print Tables> Input command was selected; only data for
the selected objects will be include in the printed output. Unchecking this check box
will cause data for all objects in the model to be included in the printed output. The
Envelopes Only box is checked when only envelopes (i.e., minimums and maximums)
for the specified data would be provided as the analysis output.
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APPENDIX A

Mesh Transitioning and Compatibility
The Automated Line Constraint

Ashraf Habibullah 1, S.E.
M. Iqbal Suharwardy 2, S.E., Ph.D.

A.1 Introduction
In the application of the Finite Element Analysis Method, the most time consuming
task is usually the creation and modification of the finite element mesh of the system.
Not to mention the fact that creation of mesh transitions from coarse to fine meshes
can be very tedious. Also matching up node points to create compatible meshes at
intersecting planes, such as walls and floors can be very labor intensive. And even if
the mesh generation is automated the mesh transitioning usually produces irregular or
skewed elements that may perform poorly. This may have adverse effects on the de-
sign, especially in regions of stress concentration, such as in the vicinity of intersecting
planes.

The object based modeling environment of ETABS & SAP2000 clearly ad-
dresses these time-consuming shortcomings of the Finite Element Method.

In the object-based modeling environment the Engineer generates the structural
model by creating only a few large area objects that physically define the structural
units such as wall panels, floors or ramps. The finite element mesh is not explicitly
created by the user, but is automatically generated by assigning meshing parameters
to the area objects. These parameters may include variables, such as mesh size, mesh
spacing and mesh grading among others. With this capabilitythe engineer can study
the effects of mesh refinement by just defining a few control parameters. The new
model with the desired level of refinement is thus created with minimal effort.

If the meshes on common edges of adjacent area objects do not match up, au-
tomated line constraints are generated along those edges. These Line Constraints en-

1President & CEO, Computers & Structures, Inc.
2Director of Research & Development, Computers & Structures, Inc.
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force displacement compatibility between the mismatched meshes of adjacent objects
and eliminate the need for mesh transition elements.

What makes this technology really powerful is that while making modifications
to the model the Engineer need only be concerned about the fewlarge physical objects
of the structure. The modified finite element analytical model gets recreated automat-
ically with any changes to the base objects.

The following examples are designed to illustrate the powerand practicality of
this technology.

A.2 Example 1: Simply Supported Plate (Mismatched
Meshing)

As illustrated in Figure A.1, this is a model of a simply supported plate, which has been
modeled in two different ways. In one case the mesh is uniformacross the plate and in
the other case the mesh is fine on one half of the plate and coarse on the other half of
the plate. In the latter case, an interpolating line constraint is automatically generated
to enforce displacement compatibility between the adjacent halves of the plate where
the mesh does not match. As shown in the figure, correlation between the two models
is very good.

Figure A.1: Simply Supported Plate with Mismatching Edges
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A.3 Example 2: Curved Ramp Supported by Curved
Wall

This example, Figure A.2, illustrates the use of Line Constraints to capture the interac-
tion of a curved shear wall supporting a curved ramp. Notice that there are no joints at
the points where the ramp element edges intersect the wall element edges. Displace-
ment compatibility along the lines of intersection of the ramp and the wall is enforced
automatically by the generation of Line Constraints along those lines. Notice how the
application of Line Constraints allows the wall and ramp mesh to retain a simple rect-
angular (or quadrilateral) configuration. A conventional finite element model would
be very irregular because it would need all the additional joints (and corresponding
elements) to allow for the ramp element and wall element edgeintersections.

A.4 Example 3: Floor Slab – Shear Wall Compatibility
This example, Figure A.3, illustrates a 3D Concrete Flat Plate Building with shear
walls and an elevator core. Again, in this model, Line Constraints automatically ap-
pear at the lines where the floor and wall objects intersect. This, of course, as in
previous examples, will enforce displacement compatibility when mesh geometries do
not match. As shown in the deformed shape of the Elevator Core, in many places the
wall meshing does not match the floor meshing. All elements meeting at common
edges, however, still show no displacement incompatibilities, even though the element
nodes do not coincide.

A.5 Example 4: Shear Wall – Spandrel Transition
This example, Figure A.4, models a Shear wall – Spandrel System, illustrating mesh
transitioning from the spandrel to the shear wall. Line Constraints are generated as
needed in any direction. In this case the Line Constraints are vertical as well as hori-
zontal.
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Figure A.2: Curved Ramp Supported by Curved Wall
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Figure A.3: Floor Slab – Shear Wall Compatibility

Figure A.4: Shear Wall – Spandrel Transition
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of Science Degrees for the University of California, Berkeley and is licensed in
California as a Civil and Structural Engineer.

Mr. Tovani has developed an extensive background in computer-aided analysis
and design. His analysis background includes work on a variety of structures
using linear and nonlinear analysis of new and existing structures in static and
dynamic loading environments. He has developed computer models on high rise
structures in excess of 100 stories and has provided design work on a variety of
structural framing systems including base isolation and other complex framing
systems. Mr. Tovani has been using the SAP and ETABS computerprograms
for over twenty-five years and has worked at CSI providing training, analysis
and modeling assistance to CSI and Engineering Analysis clients.
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