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Seminar Topics 

General Modeling Techniques 

� The advantages of an Object Oriented Integrated product 
� Model Creation & Editing, Locating with Coordinates, Grids and Snaps 
� Shortcuts and productivity features 
� Fast Draw, Replication, Extrusion, Nudge, Trim, Align, Center, Offset and Mesh 
� Perspective Views, Developed Elevations, Reference Planes and Reference Lines 
� Import/Export Features using AutoCAD 

Static and Dynamic Loading of Diaphragms 

� Code Static 
� Response Spectra 
� Time History 
� Special Seismic Load Effects 
� Pushover - Static and Nonlinear 
� Rigid, Semi-rigid, and Flexible Floor Diaphragms 

Steel Frame Design 

� Steel Frame Design with no preliminary member sizing by engineer 
� Lateral Drift Control with Automated Virtual Work and no second guessing of 

member sizes 
� Detailed Concentric Brace Design with ETABS and verification by hand 

calculations 
� Detailed Eccentric Brace Design discussion 
� Unbonded Brace Design 
� Moment Frame Design 
� Composite Beam Design 
� Vibration Analysis 
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Copyright 

The computer program ETABS and all associated documentation are proprietary and 
copyrighted products. Worldwide rights of ownership rest with Computers and 
Structures, Inc. Unlicensed use of the program or reproduction of the documentation in 
any form, without prior written authorization from Computers and Structures, Inc., is 
explicitly prohibited. 
 
Further information and copies of this documentation may be obtained from: 

 
CSI Educational Services 

Computers and Structures, Inc. 
1995 University Avenue 

Berkeley, California  94704  USA 
 

Phone: (510) 845-2177 
FAX: (510) 845-4096 

e-mail: education@csiberkeley.com (for general questions) 
e-mail: support@csiberkeley.com (for technical support questions) 

web: www.csiedu.com 
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Introduction 

This lecture is generally geared towards the intermediate user level of ETABS. However, 
if you have never used ETABS before, do not be set back. We have designed this course 
in such a way that even the inexperienced ETABS user will have no problem following 
along. All of the examples that we present (except for the few real life models in the 
beginning) will be drawn from scratch to exhibit the most general and common modeling 
techniques mentioned above. 
 
The morning will be spent discussing most of the General Modeling Techniques, and 
Static Loading. Part of the morning, as well as part of the afternoon will be spent on Steel 
Frame Design. We will finish the afternoon presentation discussing Nonlinear Time 
History (Dynamic Loading) and Push-over Analysis. 
 
We have chosen eight examples that we will describe in the presentation. In these 
seminar notes, you will find descriptions, computer model definitions, and results for 
each example. As we present each model, please feel free to follow along. 
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Example I 
General Modeling Techniques –  

Illustrative Examples Showing Shortcuts and 
Productivity Features  

  

Description 

Several existing ETABS models are presented below to illustrate various important 
modeling techniques.    

The first illustrative example shows the importance of assigning selected elements into 
“groups” and shows the powerful editing feature of the “copy assigns” command.  The 
application of rigid diaphragm verses discrete floor element modeling is also 
demonstrated in Figure 1-1 and Figure 1-2 below. 

Also discussed in this introductory chapter is the use of the “similar floors” feature of 
ETABS.   Figure 1-3 is used to illustrate the use of more than one grid system to 
construct a computer model having complex geometry. 

Figure 1-4 shows that a sloped diaphragm can be modeled easily.  Reference planes are 
added to describe the building having various roof elevations. 

 

Significant Options of ETABS Exemplified in Example 1 

� Copy Assigns 

� Group assignments 

� Flexible Diaphragms 

� Similar Floors 

� Data output into Microsoft excel 

� Moving through Elevations and Plans 

� Import from DXF file or AutoCAD files 

� Group Selection Features  

� Steel Brace Design Combinations 
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Example 1 

Computer Model Definition 

Figure 1-1 depicts a structure having 25-story building of irregular geometry.  The structure is 
base isolated at the third level above the base and has 14 grids in the X-direction and 15 grids in 
the Y-direction.  The structure also has both vertical and horizontal irregularities. 

The model is loaded with both static and dynamic loads.  Gravity loads and lateral time history 
functions are used in various combinations in the design of the structure.  

 
 

Figure 1-1 3-D view of structure 
 

Description 

Figure 1-2 shows an interior braced frame elevation.  The intent of the braced frame at this 
location was to provide resistance to lateral loads in both shear and overturning.  The horizontal 
truss elements at the roof and mid-height of the building are transfer trusses to help distribute 
overturning forces from the interior braces to the building exterior.  If the top and bottom chord 
elements of the horizontal trusses are to be modeled properly, the joints must be disconnected 
from the rigid floor diaphragms to allow shortening or elongation of the horizontal truss chord 
elements. 

To illustrate the use of the “copy assigns” command, an entire column line can be copied and 
assigned “pasted” anywhere within the computer model.  Note that any assignment including 
sections, releases, offsets, output stations, local axis, property modifiers and line types can all be 
captured and assigned in one simple command. 
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Figure 1-2 Elevation of an interior braced frame 
 
 

Example 2 

Significant Options of ETABS Exemplified in Example 2 

� Multiple Grids  

� Element Local Axis 

 

Computer Model Definition 

Figure 1-3 depicts a structure having two grids.  The first grid consists of a Cartesian coordinate 
system.  The second grid is a cylindrical coordinate system.  
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Figure 1-3 Plan of Structure with Multiple Grids 
 
 
 

Example 3 
 
Significant Options of ETABS Exemplified in Example 3 

� Discrete Roof Element Modeling  

� Sloped Diaphragms 

� Reference Planes 

� Reference Lines 

� Divide Line/ Join Line Options 

� Merge Points 

� Align Points 
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Computer Model Definition 

Figure 1-4 consists of a gymnasium structure that has multiple roof diaphragms.  Several of the 
roof diaphragms are sloped between various roof elevations.  The structure has includes various 
bracing elements which have been located using the “divide line” option.  Reference planes 
have also been introduced to aid in the development of the model.     

 

 
 

Figure 1-4 3-D image of Structure with Sloped Diaphragms 
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EXAMPLE II 
More General Modeling Techniques –  
Four Story C-Shaped Steel Frame Structure  
 

  

 

Description 

This is a four-story C-shaped Model, subjected to vertical static loading and computer-
generated earthquake loading per the 1997 Uniform Building Code.  The structure 
consists of steel beams and columns along with a concrete deck on every level. 

 

Significant Options of ETABS Exemplified 

� Quick-draw Beam and Column Generation 

� Floor Area Generation 

� Expand/Shrink Areas Option 

� Steel Design Optimization  

� Modes Shapes 

� Lateral Displacement Targets 

� Local Axis Orientation 
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Computer Model Definition 

The structure is a C-shaped 4-column line, 3-bay system. Each bay is spaced 24 feet 
apart. Each story level is 12 feet in height. Kip-inch-second units are used.  The modulus 
of elasticity is 29000 ksi. To see frame geometry, please refer to Figure 2-1. 

Other parameters associated with the structure are as follows:   

Coefficient of Thermal Expansion  = 6.500E-06 
Poisson's ratio     = 0.3  
Minimum Yield Stress, Fy    = 50 ksi 
Minimum Tensile Strength, Fu  = 65 ksi 

    Deck Properties: 
  
         Slab Depth     = 3.25 in 
         Deck Depth     = 3 in 
 Rib Width     = 6 in 
 Rib Spacing     = 12 in 

 
 

  Service Loads: 
   
 Superimposed Dead Load Roof  = 30 psf    
     Story 3  = 30 psf 
     Story 2  = 30 psf 
     Story 1  = 30 psf 
 
 
For the UBC97 seismic load analysis, the following code parameters associated 
with the structure are as follows: 

  UBC Seismic zone factor, Z    = 0.40  
UBC Soil Profile Type     = SC   
UBC Importance factor, I     = 1.0 
UBC Overstrength Factor    = 8.5 
UBC coefficient Ct     = 0.035 
UBC Near source Factor, Seismic Source Type = B 

           Distance to Source     = 15 km 
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Quick Draw Beam and Column Generation 

Create Lines at Regions or at Clicks 

The Draw menu -> Draw Line Objects -> Create Lines in Region or at 
Clicks (plan, elev, 3D) command works in two different ways.  

Click on any grid line (in plan view only) and a line object is drawn on 
that grid line between the two adjacent intersecting grid lines from the 
same coordinate/grid system.  

Alternatively, in all views, depress and hold down the left button on your 
mouse. While keeping the left button depressed, drag the mouse to "rubber 
band" a window around one or more grid line segments. Then release the 
left mouse button. Line objects are automatically placed at each grid line 
segment included in the "rubber band" window. The term grid line 
segment in this paragraph means that portion of a grid line between the 
two adjacent intersecting grid lines from the same coordinate/grid system. 

 Create Columns at Regions or at Clicks 

After you have activated the Draw menu -> Draw Line Objects -> Create 
Columns in Region or at Clicks (plan) command there are two ways you 
can draw the columns. They are:   

Left click at any location in a plan view to draw a column (vertical line 
object below). 

Working in plan view, depress and hold down the left button on your 
mouse. Perform the same operation when creating line at regions. 
Columns (vertical line objects below) are automatically placed at each grid 
line intersection of two grid lines in the same coordinate/grid system 
included in the "rubber band" window. 

The columns (vertical line objects) extend from the story level that you 
draw them on to the story level below, and, of course, also to other story 
levels if you have the similar stories feature in the ETABS status bar 
activated. 
 

Create Columns at Regions or at Clicks 

The Draw menu -> Draw Line Objects -> Create Secondary Beams in 
Region or at Clicks (plan) command allows you to draw typical infill 
(secondary) beams for an entire grid line space (beam bay) in a single 
click. The grid line space is defined by four adjacent intersecting grid 
lines. If beams are already in the grid line space, the spacing and extent 
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(length) of the secondary beams is based on the existing beams rather than 
the grid lines. The figure below shows an example of a grid line space and 
secondary beams. Note that secondary beams are not included on the grid 
lines. 

 
 
Draw Area Object 
 

To draw an area object using the Draw menu -> Draw Area Objects -> Draw 
Areas (plan, elev, 3D) command, left click once at the first corner point of the 
area, drag the mouse to the next corner point and left click, and so on to define 
each corner point of the area object. Note that as you drag the mouse a dashed line 
is visible indicating the current extent of the area object. 
 
When you reach the last corner point of the area object, double left click to finish 
the object or single left click and then press the Enter key on the keyboard. 
  
Area objects drawn using this command must have at least three corner points. 
Typically area objects are limited to no more than four corner points; however, 
there is no limit on the maximum number of corner points allowed for horizontal 
area objects (in the global XY plane). 
 
After using these functions our C-shaped model looks like this: 

 
 

 
 
 

Figure 2-1 3-D View of Structure 
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Results 
 
After running the analysis (under menu->Analyze-> Run Analysis), go to Design->Steel 
Frame Design-> Start Design Check of Structure.  ETABS tells you that there are 132 
steel frames whose analysis and design sections differ. Design is an iterative process. The 
sections that you use to run your original analysis are not typically the same sections that 
you end up with at the end of the design process. You always want to be sure to run a 
building analysis using your final frame section sizes and then run a design check based 
on the forces obtained from that analysis. The Design menu -> Steel Frame Design -> 
Verify Analysis vs. Design Section command is useful for making sure that the design 
sections are the same as the analysis sections. 
 
After running the analysis and design again, we choose to see the deflection of Joint 13 
shown in Figure 2-2 below: 
 

 

Joint 13

 
Figure 2-2 Deflected Shape Under Earthquake Load Case 
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Set Lateral Displacement Target 

 
You can see that Joint 13 on Story 4 has a displacement of 1.14 inches in the X-
direction. If we want to set the maximum displacement on this joint not to exceed 
.9 inches, we can set a lateral displacement target. From the menu, click Design -> 
Steel Frame Design -> Set Lateral Displacement Targets command to open the 
Displacement Optimization form where you can specify displacement targets for 
various load cases. Enter a maximum displacement of .9 inches for the lateral 
earthquake load in the X-direction. 
 
The intent is to pick a point, typically at the roof level of your building, and 
specify a maximum displacement target (in any direction) for one or more load 
cases.  For displacement optimization, ETABS predicts which members should be 
increased in size to control the displacements based on the energy per unit volume 
of the members. The members with more energy per unit volume are increased in 
size by a larger percentage than those with smaller energies per unit volume. 
Some members with small energy per unit volume may be decreased in size if 
they are still acceptable for strength considerations. 
 
Next, run the analysis and design again.  ETABS will tell you there are 86 frames 
whose analysis and design sections differ.  This means 86 frames sizes have 
changed in order to control the displacement at joint 13. ETABS will then ask you 
whether you wish to select these sections. Click Yes.  You will notice members 
ONLY parallel to the x direction have increased in size. The deflection at Joint 
13 is .81 inches.  If you keep iterating, the deflection will get closer to the 
desired .9-inch deflection. 
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Joint 13 

 
Figure 2-3 Frame Elements in X-Direction 

 
 
 

Mode Shapes  
 

Click Display -> Show Mode Shape command to access the Mode Shape 
form. Specify the mode whose deformed shape you would like to plot. 
This structure has been modeled as a flexible diaphragm.  This means the 
model will NOT rotate about an axis perpendicular to its own plane 
(global Z-axis) as a rigid body. The deflected shape below shows portions 
of the model deflecting in different directions. 
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Figure 2-4 C-Shaped Structure- Mode Shape 11 
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EXAMPLE III Advanced Modeling Techniques – 
Eight Story Parking Garage Structure  

  

 

Description 

This is an eight-story parking garage structure with curved ramps located at each level. 
Each floor has a 12 ft story height.  Each bay is 24 feet long in the X-direction and 36 
feet long in the Y-direction. The structure is laterally supported by a curved shear wall 
system located at the edge of the ramp system.    

. 

Significant Options of ETABS Exemplified 

� Replication Features 

� Extrude Lines to Areas Feature 

� Ramp Generation 

� Curved Shear Wall Generation 

� Draw Developed Elevations 

� Auto Line Constraint Feature 

� Creation of OpenGL Views 
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Computer Model Definition 

Grid and Line Generation  

The structure is an 11-column line, 5-bay system.  Kip-inch-second units are used.  
Spacing in the X and Y direction is 24 and 36 feet respectively. It is an 8-story structure 
with 12 ft story heights. 

To create this model, go to elevation line 3.  Draw a line from Grid line A to Grid line C.  
Select this line, go to Edit-> Replicate-> Story Tab and select the EVEN story levels. 
(Holding down the CTRL key while selecting levels). Draw a line from Grid line I to 
Grid line K and replicate this line on all odd story levels.  Next, draw a line starting at 
level 8 diagonally down to level 7 connecting each line at every level. (In this example, it 
does not matter which beam size you select). Currently, the model should look like this: 

 
 

 
     
 

Figure 3-1 Elevation of Ramp Structure 
 
Ramp Generation 
 
Next, select all flat beams on every level and every other inclined beam element. Go to 
Edit -> Extrude Lines to Areas -> Linear.  In the Increment Data box, enter 36 feet for dy 
and number of replications = 2.  Now, select all of the flat beams again and the inclined 
beams that were not selected the first time. Perform the same extrusion application except 
use –36ft for dy. Your model should now look like Figure 3-2: 

 
 



          
 

“Optimized Modeling and Design of Steel Structures using ETABS”  
 

- 21 - 

 

 
 

Figure 3-2 3-D View of Ramp Structure 
 
Circular Edge Ramp Generation 
 
Now, we are ready to create our circular ramp.  Go to Elevation A, and draw a line from a 
point in between Grid line 3 and 4 to Grid line 5. (Make sure snap to lines and edges is 
activated under Draw-> Snap to -> Line and Edges). Replicate this line on all even floors. 
Select all lines in Elevation A, go to Edit-> Extrude lines to Areas-> Radial tab. The 
ramp is a semi-circle so enter 10-degree angles extruded 18 times creating a 180 degree 
curved surface.  The total drop of the ramp is 2 stories or 288 in.  
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The ramp is rotated 
about Grid line 3 
and A. Y coordinate 
is 864. 

 
 

Figure 3-3 Extrude Lines to Areas Box 
 

After completing this step, your model should look like Figure 3-4: 
 

 
 

Figure 3-4 Circular Ramp Structure 
 
Curved Shear Wall Generation 
 
Now, we are interested in creating a curved shear wall surface around the edge of the 
circular ramp surface, which will run the full height of the structure.  Go to floor plan 8 
and select all stories the drop down box at the bottom right hand corner of the screen. 
This will create shear walls on all floors instead of just the 8th floor. Under View -> Set 
Building View Options -> de-select the toggle labeled invisible under point objects.  This 
will enable the user to view and snap to joints when creating the curved shear wall.  Go to 
the Draw ->Draw Area Objects -> Draw Walls and click on the joint located at the 
intersection of Grid line A and 5.  Keep clicking on every joint around the edge of the 
ramp. When you get half way around the semi-circle, you will need to go to floor plan 7 
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because the rest of the joints that are located below Story 8 cannot be seen. Complete the 
semi circle once you get to the intersection of Grid line 1 and A.   
 
Developed Elevation 
 
Developed elevations can simultaneously show multiple faces of the building in a single 
"unfolded" elevation view. To draw a developed elevation, from the menu select Draw-> 
Draw Developed Elevation Definition, type a name for the developed elevation in the edit 
box in the Developed Elevations area of the form and click on ‘Add New Name’.  Next, 
in floor plan 8, draw an elevation the same way you drew the curved shear wall, by 
clicking on the edge joints of the ramp until you’ve created a semi-circle again. To view 
the elevation, click the View menu-> Set elevation view and select the name of your 
Developed Elevation.   
 
Note: If the Options menu -> Window command is set to two or more windows and 
those windows are set to Plan or 3D View, the location of the developed elevation is 
illustrated with a cyan line (default) in the Plan and 3D view windows. Click on a couple 
of wall elements and delete them. This will create an opening in the curved shear wall 
element.  Your model should look like Figure 3-5: 
 
 
 
 

 
 
 

Figure 3-5 Circular Ramp Structure with Curved Shear Wall 
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Auto Line Constraint 
 
If you look closely at Figure 3-5, you will notice that the shear wall nodes and ramp 
nodes do not connect.  In typical finite element analysis, shell elements are connected to 
other elements at corner points only. When an element does not frame into the corner 
point of a shell element, but instead frames into the edge of the shell element, no 
connection exists between the element and the shell element. ETABS is able to perform 
the analysis in this fashion. However, ETABS also has the capability of using an auto line 
constraint. The ETABS auto line constraints feature allows you to specify that elements 
framing into the edge of a shell element be connected to the shell element. ETABS 
internally takes care of connection between the elements by constraining points lying 
along an edge of the shell element to move with that edge of the element. Additional 
information regarding the auto line constraint functionality in ETABS can be found in 
“Mesh Transitioning and Compatibility:  The Automated Line Constraint in ETABS & 
SAP2000”.  (http://www.csiberkeley.com/images/line_constraint.pdf). 

http://www.csiberkeley.com/images/line_constraint.pdf
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EXAMPLE IV Concentric Braced 4-Story Steel Frame 
Structure 

  

 

Description 

This is a four-story special concentrically braced frame structure, subjected to vertical 
static loading and computer-generated earthquake loading per the 1997 Uniform Building 
Code.  X bracing is placed in specific bays to resist the lateral forces. There are two decks 
per floor that span in different directions.   

 

Significant Options of ETABS Exemplified 

� Rigid Diaphragm Assignments 

� Use of Section Cuts 

� Shell Element Axis Rotation 

� Replication Techniques 

� Deck Element Options 

� Quick Draw Brace Generation  

� Automated Earthquake generation 
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Computer Model Definition 

The structure is an L-shaped 13-column line, 12-bay system.  Kip-inch-second units are 
used.  The modulus of elasticity is 29000 ksi. To see frame geometry, please refer to 
Figures 4-1 and  
4-2. 

 Other parameters associated with the structure are as follows: 

    Deck Properties: 
  
         Slab Depth     = 3.25 in 
         Deck Depth     = 3 in 
 Rib Width     = 6 in 
 Rib Spacing     = 12 in 

 
 

  Service Loads: 
  
 Live Load:   Roof  = 20 psf 
     Story 3  = 80 psf 
     Story 2  = 80 psf 
     Story 1  = 80 psf  
  
 Superimposed Dead Load Roof  = 73.7 psf    
     Story 3  = 75.4 psf 
     Story 2  = 75.4 psf 
     Story 1  = 75.4 psf 
 
In this model, the dead load self-weight multiplier has been set to zero. This can 
be found under Define->Static Load Case. The only dead load associated with this 
example is the superimposed dead loads listed above.  

 

For the UBC97 seismic load analysis, the following code parameters associated 
with the structure are as follows: 

  UBC Seismic zone factor, Z    = 0.40  
UBC Soil Profile Type     = SD   
UBC Importance factor, I     = 1.0 
UBC Overstrength Factor    = 6.4 
UBC coefficient Ct     = 0.035 
UBC Near source Factor, Seismic Source Type = B 

         Distance to Source     = 8 km 
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Figure 4-1 3-D view of structure 
 
 

 
 

 
Figure 4-2 Elevation Line M 
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Rigid Diaphragm Assignment 

 
Rigid diaphragms can only be horizontal. Thus rigid diaphragm assignments are not 
applicable to wall-type and ramp-type area objects. They are only applicable to floor type 
area objects and to null-type area objects that are in a horizontal plane.  In ETABS, a 
rigid diaphragm translates within its own plane (global X-Y plane) and rotates about an 
axis perpendicular to its own plane (global Z-axis) as a rigid body. Designating an area 
object as a rigid diaphragm has no effect on the out-of-plane behavior of the area object. 
For example, if you specify a concrete floor slab to have plate-bending properties (i.e., 
out-of-plane bending capability), applying a rigid diaphragm constraint has no effect on 
the out-of-plane bending of the floor. It only affects in-plane behavior of the floor.  
Within ETABS, assigning a rigid diaphragm to an area object provides a diaphragm 
constraint to all of the corner points of the area object and to any additional point objects 
that are enclosed within the boundaries of the area object. This includes any points 
(joints) that are created as a result of ETABS automatically meshing the area object. 
 
 
Results 
 
Section Cut Forces 
 
There are two options available to define Section Cuts: 
 

1. The first option is to define the location of the cut.  Use the Define menu -
> Section Cuts command to obtain resultant forces acting at section cuts 
through a model. Define section cuts before or after an analysis is run; 
however, it is safest to wait until after the analysis has been run. Typically 
do not define section cuts, and more importantly, the groups used in the 
section cut definition, until all manual meshing of the model (if any) has 
been completed. If the groups are defined before manual meshing, some of 
the point objects that should be in the group may not yet be created. 

 
2.  The second option is to manually draw the section cut on any portion of 

the model. This can be by utilizing the Draw->Draw Section Cut option.   
You must make sure that the model has been analyzed and you are 
viewing a member force/stress diagram.  This can be found under Display-
> Show Member Force/Stress Diagram-> select either frame or shell 
forces.  This second option is used in this example to obtain section cuts 
forces.  

 
 

 
 
 
 



          
 

“Optimized Modeling and Design of Steel Structures using ETABS”  
 

- 29 - 

To obtain shell stress forces on Story 4 between Grid lines L and M, go to Draw->Draw 
Section Cut.  Draw a line parallel to Grid line M. The flashing line represents to section 
cut along Grid line M. Section Cut forces will now be visible on the screen. Please refer 
to Figure 4-3 and 4-4. 
 

 

Section Cut

 
Figure 4-3 Stress Diagram (S12) for Earthquake Load Case 

 
In Figure 4-3, you can the high stress concentrations along line M between Grid lines 4 
and 6.  This is where the special concentric braced frames are located.  You can see that 
there are also braces along Grid line A.  
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Figure 4-4 Section Cuts force output 
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EXAMPLE V Two Story Steel Braced Frame Structure – 
Vertical and Lateral Load Analysis 

  

 

Description 

This is a two story braced frame structure, subjected to vertical static loading and 
computer generated earthquake loading per the 1997 Uniform Building Code. The lateral 
forces are being resisted by concrete shear walls and steel braces.  The structure contains 
heavy mechanical equipment loads on the Roof level.   

The frame geometry is shown in Figure 5-1 and Figure 5-2. 

 

Significant Options of ETABS Exemplified 

� Automated Earthquake and Wind Load Generation 

� Shell Element Options 

� Use of Null floor elements 

� Story and Grid Edits 

� Mass Source Options 

� Steel Brace Overwrite Options 

� Shear Wall Generation 

� Quick Draw Brace Generation  

� Steel Brace Design 

� Composite Beam Design 
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Computer Model Definition 

The structure is a 4-column line, 3-bay system.  Kip-inch-second units are used.  The 
modulus of elasticity is 29000 ksi. 

 Other parameters associated with the structure are as follows: 

Coefficient of Thermal Expansion  = 6.500E-06 
Poisson's ratio     = 0.3  
Minimum Yield Stress, Fy    = 50 ksi 
Minimum Tensile Strength, Fu  = 65 ksi 
 
 

    Deck Properties: 
  
         Slab Depth     = 3.5 in 
         Deck Depth     = 3 in 
 Rib Width     = 6 in 
 Rib Spacing     = 12 in 

 
 

  Service Loads: 
  
 Live Load:   Roof  = 20 psf 
     Story 1  = 125 psf 
     Deck  = 100 psf  
  
 Superimposed Dead Load Roof  = 30 psf 
     Story 1  = 31 psf 
     Mechanical = 188 psf 

 

For the UBC97 seismic load analysis, the following code parameters associated 
with the structure are as follows: 

  UBC Seismic zone factor, Z    = 0.40  
UBC Soil Profile Type     = SD   
UBC Importance factor, I     = 1.0 
UBC Overstrength Factor    = 5.5 
UBC coefficient Ct     = 0.035 
UBC Near source Factor, Seismic Source Type = B 

         Distance to Source     = 10 km 
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Figure 5-1 3-D view of structure 
 

 
 

Figure 5-2 Plan view of Story 1 
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Mass Source Option 
 
In ETABS, the user has the option of choosing one of three options for defining the 
source of the mass of a structure. Click the Define menu -> Mass Source command to 
bring up the Define Mass Source form. The following options appear on the form: 
 

1. From Self and Specified Mass:   
 

Each structural element has a material property associated with it; one of 
the items specified in the material properties is a mass per unit volume. 
When the ‘From Self and Specified Mass’ box is checked, ETABS 
determines the building mass associated with the element mass by 
multiplying the volume of each structural element times it’s specified 
mass per unit volume. This is the default. It is also possible to assign 
additional mass to account for partitions and cladding, etc.  ETABS adds 
any additional mass assignments to the element mass to derive a total 
mass. You cannot have a negative mass in ETABS. 

 
2. From Loads: 

 
This specifies a load combination that defines the mass of the structure. 
The mass is equal to the weight defined by the load combination divided 
by the gravitational multiplier, g. This mass is applied to each joint in the 
structure on a tributary area basis in all three translational directions. 

  
3. From Self and Specified Mass and Loads: 
 

This option combines the first two options, allowing you to consider self-
weight, specified mass, and loads in the same analysis.  

 
 
It is important to remember when using the ‘From Self and Specified Mass and 
Loads’ option, NOT to include the Dead Load Case in the ‘Define Mass Multiplier 
for Loads’ box. This will account for the dead load of the structure TWICE.  
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Results 
 
Base Shear Calculation 
 
This information shown below can be printed using:  

File -> Print Tables -> Input -> Auto Seismic Loads. 
      
 

AUTO SEISMIC INPUT DATA 
  
Direction:X 
Typical Eccentricity = 5% 
Eccentricity Overrides: No 
   
Period Calculation: Program Calculated 
Ct = 0.035 (in feet units) 
   
Top Story: STORY2 
Bottom Story: BASE 
 

    V = (Cv I W) / (R T)                                   (Eqn. 1) 
     V <= 2.5 Ca I W / R                                    (Eqn. 2) 
     V >= 0.11 Ca I W                                (Eqn. 3) 
     V >= 0.8 Z Nv I W / R,      (Eqn. 4) 
   
     If T <= 0.7 sec, then Ft = 0 
     If T > 0.7 sec, then Ft = 0.07 T V <= 0.25 V 
  
  

AUTO SEISMIC CALCULATION RESULTS 
  
     Ta = 0.4260 sec 
    T Used = 0.1865 sec 
     W Used = 3910.77 
   
    V (Eqn 1) =0.8446W 
     V (Eqn 2) =0.2031W 
     V (Eqn 3) =0.0581W 
     V (Eqn 4) =0.0788W 
   

V Used = 0.2031W = 794.19 Kips   
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Steel Frame Design 
 

After running the Steel Frame Design, (See Figure 5-3) the user can right-click on 
any steel frame element to view the Steel Stress Check Information. By clicking 
the Details button, the design details for the selected design combination and 
station location are shown. (See Figure 5-4): 
 

 

 

Calculation 
for brace 
shown in 
Figure 5-4 
below. 

   
Figure 5-3 Elevation E 

 

 
 

Figure 5-4 Steel Stress Check Details Output 
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Composite Beam Design 
   

After running the Composite beam design, the user can view the results using two 
different methods: 
        
1. Text Format:  File -> Print Tables -> Composite Beam Design 
2.    Graphically:   Design -> Composite Beam Design -> Display Design Info. 
 
Shown below in Figure 5-5, is an example of how the composite beam design 
results can be displayed graphically.  You can see that the beams sizes chosen 
between Grid Lines D and E are larger because this is where the deck/mechanical 
loads were assigned. A more complete discussion of Composite Beam Design 
can be found in Example VI. 
 

 
 

Figure 5-5 Composite Design Results Output 
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EXAMPLE VI 
Composite Beam Design  
 

  

 

Description 

Composite beam design is a powerful feature in ETABS. In this section, we will be 
discussing 2 composite beam design examples. The first model will be using the AISC 
LRFD 99 code. The second model will be using the AISC-ASD 89 code. 

Significant Options of ETABS Exemplified 

� Deck Properties 

� Composite Beam Properties 

� Construction Loading 

� Auto Load Combinations 

� Stud Spacing Options 

� Partial Composite Limits 

� Vibration 
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Example 1 

This is an example of composite flexural member design using the LRFD 99 code. This 
model can be found in the AISC-LRFD 99 3rd Edition example 5.6.   The model is a one-
story 3-D steel frame structure, subjected to dead and live loads. We will look at the 
unshored and shored condition of this model. 

 

 

 
 

Figure 6-1 3-D view of Structure 
 

Computer Model Definition 

The beam span is 40 feet and the beam spacing is 10 feet.   The modulus of elasticity is 
29000 ksi. To see frame geometry, please refer to Figure 6-1. 

 Other parameters associated with the structure are as follows: 

Coefficient of Thermal Expansion  = 6.500E-06 
Poisson's ratio     = 0.3  
Minimum Yield Stress, Fy    = 50 ksi 
Minimum Tensile Strength, Fu  = 65 ksi 

    Deck Properties: 
  
         Slab Depth     = 3 in 
         Deck Depth     = 3 in 
 Rib Width     = 6 in 
 Rib Spacing     = 12 in 
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Service Loads: 
 

   
Load Service 

Load 
Load Factor Factored Load 

Dead .9 k/ft 1.2 1.1 k/ft 
Live 2.5 k/ft 1.6 4.0 k/ft 
Total 3.4 k/ft ----- 5.1 k/ft 

 
 

Composite Beam Design Preferences 

Click the Options menu -> Preferences -> Composite Beam Design 
command to bring up the Composite Beam Design Preferences form.  On 
the Composite Beam Design Preferences form, click in the drop-down 
boxes or edit boxes and select or enter the desired value. Preferences 
control a variety of items that affect the look and feel of the program, the 
default behavior of the design postprocessors, and how the program 
considers live load reduction. Composite Beam Design Preferences are 
code specific. The Vibration tab gives the user an option to state the 
percent of live load plus reduced live load considered (in addition to full 
dead load) when computing weight supported by the beam for use in 
calculating the first natural frequency of the beam. Also, ETABS can 
consider Murray's minimum damping requirement as one of the criteria to 
be used for determining if a beam section is acceptable. For an explanation 
of the code-specific preference items and their associated possible values, 
default values, and a brief description of the items, click the Help menu -
> Documentation and Tutorials command. Click Technical Notes - 
Composite Beam Design. Click your selected code and the Preferences 
Technical Note for that code.  

 
 

Composite Beam Property Overwrites 

Use the Design menu -> Composite Beam Design -> View/Revise 
Overwrites command to review or change the composite beam overwrites. 
You may not need to assign any composite beam overwrites; however the 
option is always available. If your design includes cover plates or user-
defined shear connector patterns, assign them using the overwrites option. 
The composite beam design overwrites are basic properties that apply only 
to the beams to which they are specifically assigned. Some of the default 
overwrite values are based on composite beam preferences. Thus, define 
the preferences before defining the overwrites (and before designing or 
checking any composite beam). 
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Shear Studs is one of the tabs available in the composite beam overwrites. 
You can indicate if a user-defined shear connector pattern is defined, 
specify uniform spacing of shear studs along the beam and overwrite 
maximum/minimum longitudinal spacing of shear studs along the length 
of the beam.  The shear stud form is shown in Figure 6-2:  

 

Figure 6-2 Composite Beam Overwrites- Shear Studs 
 
 
Under the Miscellaneous tab shown in Figure 6-2, the user can set the 
minimum and maximum value of percent composite connection 
considered for the beam. In the Results section of this example, we will 
show you where the Minimum and Maximum PCC is calculated. (See 
arrow #2 in Figure 6-3). Under the Vibration Tab, you have the option to 
indicate whether Neff is user-specified or calculated by the program based 
on specified beam spacing. You can also state the effective number of 
beams resisting a heel drop impact.  

Composite Beam Design Combinations 

It is not necessary to run the analysis or select an element before using the 
Design menu -> Composite Beam Design -> Select Design Combo 
command.  
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Click the Design menu -> Composite Beam Design -> Select Design 
Combo command to open the Design Load Combinations Selection form. 
Review the default composite beam design load combinations defined by 
ETABS or designate your own design load combinations. Note that for 
composite beam design, separate design load combinations are specified 
for construction loading, final loading considering strength, and final 
loading considering deflection. Each of these types of design load 
combinations is specified in a separate tab in the form. 

The default composite beam design load combinations have names such as 
DCMPC1, and so forth, as follows: 

• DCMPCn: The D stands for Design. The CMP stands for 
composite. The last C stands for construction. The n item is a 
number. Design load combinations with this type of designation 
are the ETABS default for construction loading in composite 
design. 

• DCMPSn: The D stands for Design. The CMP stands for 
composite. The S stands for strength. The n item is a number. 
Design load combinations with this type of designation are the 
ETABS default for strength considerations under final loading in 
composite design. 

• DCMPDn: The D stands for Design. The CMP stands for 
composite. The last D stands for deflection. The n item is a 
number. Design load combinations with this type of designation 
are the ETABS default for deflection considerations under final 
loading in composite design. 
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Results 

 
     The resulting flexural required strengths for the total factored load are: 

  Mu = wL2

                        8 
      = (5.1 k/ft) (40ft) 2

         8 
          =  1020 k-ft 
 
            Vu   = wL 
          2

                                                 = (5.1 k/ft)(40ft)    
2  

      =  102 k 
 
From Table 5-13, Qn= 26.1 k/stud and the number of shear studs required is: 

 
  2ΣQn = 2(810 k)    =     62.1 → 64 studs 

     Qn       26.1 k/stud 
 
After you run the analysis and composite beam design, right-click on a beam 
element to activate the interactive composite beam design box. Click on Details to 
see a summary of the beam design. The AISC-LRFD example calculated 64 shear 
stud connectors required. If you look below under the Summary in Figure 6-3, 
you can see ETABS calculates 65 studs required. (See Arrow #1): 
 



 
 

#1
#2
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Figure 6-3 Composite Beam Design Details 
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Example 2 

This is an example of composite flexural member design using the AISC-ASD 89 code. It 
is a fully composite interior floor of an office building. This model can be found in the 
AISC-ASD 89 9th Edition, example 16.  The model is a one-story 3-D steel frame 
structure, subjected to dead and live loads.  

 

 

 
Figure 6-4 3-D View of Structure 

 

Computer Model Definition 

The one story structure has a span length of 36 feet with beam spacing of 8 feet. . Kip-
inch-second units are used.  The modulus of elasticity is 29000 ksi. To see frame 
geometry, please refer to Figure 6-4. 

Other parameters associated with the structure are as follows:   

Weight of Concrete    = 145 pcf 
Poisson's ratio     = 0.3  
Minimum Yield Stress, Fy    = 36 ksi 
Minimum Tensile Strength, Fu  = 65 ksi 

 Concrete Compressive Strength, f’c  = 3 ksi 
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    Deck Properties: 

  
         Slab Depth     = 2 in 
         Deck Depth     = 2 in 
 Rib Width     = 2.5 in 
 Rib Spacing     = 6 in 

Stud Diameter     = .75 in. 
Stud Height     = 3.5 in. 
 

Building Loading   
  

Live Load     = 100 psf 
 Partition Load     = 20 psf 
 Ceiling Load     = 8 psf    
  

Results      
  

After you run the analysis and composite beam design, right-click on a beam 
element to activate the interactive composite beam design box. Click on details to 
see a summary of the beam design. The AISC-ASD example calculated a 
W21x44 beam size with 30 shear stud connectors. Figure 6-5 shows that ETABS 
calculated the same W21x44 beam size with 31 shear stud connectors.  This can 
be displayed by selecting Design->Composite Beam Design->Display design 
info->select beam sections and shear stud layout. 

 

 
 

Figure 6-5 Partial Plan-Composite Beam Design Results 
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EXAMPLE VII 
Nonlinear Time History Analysis 

 
  

 

Description 

This example consists of 3 simple 2-D frames, subjected to a nonlinear Time History 
Analysis with the use of link elements. The first frame has no link properties assigned to 
it. The second frame contains damper link properties, as it’s lateral force resisting system. 
The third frame contains isolator link elements.  The frame geometry is shown in Figure 
7-1. 

 

Significant Options of ETABS Exemplified 

� Time History Function Definition 

� Time History Case Definition 

� Damper/ Isolator Link Properties 

� Creation of .AVI Files 

� Time History Traces 

� Response Spectrum Curves 
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Computer Model Definition 

These 3 frames contain one bay that is spaced 24 feet apart. Each frame is 3 stories high. 
Each story level is 12 feet in height. Kip-inch-second units are used.  The modulus of 
elasticity is 29000 ksi. A point mass of .25 is assigned to each joint in the X and Y-
directions.  

 

Link Element Definition 

Damper and Isolator Link Element 

Click the Define menu -> Link Properties command to bring up the 
Define Link Properties form. Click the Add New Property button to 
access the NL link property data form.  Select the Damper or Isolator 
link element from the pull-down menu Enter the desired values for 
Mass, Weight, and Rotational Inertia. Note that the mass is for the 
entire length of the element and is not mass per unit volume.  
Typically, link elements can have two sets of properties assigned to 
them:  

• Linear properties, can be assigned to linear link elements 
only. The linear property that you specify for each of the six 
degrees of freedom of a linear link element is an effective 
stiffness. This is simply a spring stiffness. 

• Nonlinear dynamic properties, which are used for nonlinear 
dynamic (time history) analysis. Note that you must have the 
nonlinear version of ETABS to use the nonlinear dynamic link 
properties.   

The linear properties that you specify for each of the six degrees of 
freedom of all types of link elements other than linear link elements 
are an effective stiffness and effective damping. In such cases, the 
effective stiffness is, again, simply a spring stiffness. The effective 
damping specifies dashpot-type damping; it is not a specification of 
percent critical damping. 

In a linear analysis ETABS converts the specified effective damping 
for a link element to modal damping. It then adds the modal damping 
calculated for all link elements in the model that have effective 
damping specified to any modal damping already specified for the 
structure as a whole to get the final modal damping. ETABS reports 
this final modal damping in the printed analysis output for building 
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modes. To get this output, click the File menu-> Print Tables -> 
Analysis Output command and check the Building Modal Info check 
box. 

Link Element Assignment 

Damper Link Element 

Go to Draw->Draw Line Object->Draw Line and in the Properties of 
Object Box, select a NONE Property. Draw diagonal line on every 
level of the middle frame. Select these lines and go to Assign-
>Frame/Line-> Link Property and select the Damper property previous 
defined.  

 Isolator Link Element     

Select the bottom joints on the 3rd frame and go to Assign-
>Joint/Point->Restraints and select all restraints in all 6 directions. 
Select these same joints and go to Assign->Joint/Point-> Link 
Properties. Select the Isolator property previously defined.  

The model should look like Figure 7-1: 

 

Figure 7-1 Three Frame Time History Model 

 

Time History Function and Case Definition 

In this example, we are interested in defining a pre-defined time history function 
from a text file. Go to Define->Time History Function->Add Function from File.  
Click the Browse button and select the time history text file. You can view time 
history graph by clicking on the Display Graph button. Fill in the Function File 
information: 
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Figure 7-2 Time History Function Definition 
 

 
Next, we define the Time History case data.  Go to Define->Time History Cases-
> Add New History. There are many options available including Analysis Type, 
Number of Output Time Steps and Output Time Step Size. The output time step 
size is the time in seconds between each of the equally spaced output time steps. 
Do not confuse this with the time step size in your input time history function. 
The number of output time step size can be different from the input time step size 
in your input time history function. The number of output time steps multiplied by 
the output time step size is equal to the length of time over which output results 
are reported.  
 
We are interested in assigning the time history acceleration in the x-direction. The 
time history is a 12-second record, so enter 6000 time steps and time step size of 
.002 seconds. 
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Results 

 
Creation of .AVI video files   

After running the analysis (under menu->Analyze-> Run Analysis), ETABS has 
the capability of creating an .AVI animation file. Use the File menu -> Create 
Video-> Time History Animation command to create videos in ETABS showing 
the movement of the structure during any time history analysis that has been run. 
Enter the input data for the video file:  

The Start Time, End Time, Time Increment boxes must be filled to create the 
video file. Use the default or define start and end times and time increments. The 
time increment controls how many different pictures (frames) of the deformed 
shape of the structure are created. For example, a time increment of 0.1 means a 
picture (frame) of the deformed shape is created for every one-tenth second of the 
time history.  

Time History Traces 

After running a time history analysis, click the Display menu -> Show Time 
History Traces command to access the Time History Display Definition form. Use 
the form to specify the appropriate data to plot various time history curves. 

A time history trace is simply a plot of a vertical time history function versus a 
horizontal time history function. The vertical time history function can be any 
defined time history function. Although the horizontal time history function 
defaults to Time, it can be any defined time history function. 

When you click the Display menu -> Show Time History Traces command, 
ETABS automatically creates time history display functions for all selected 
objects. Use the Time History Display Definition form to define additional time 
history display functions as desired. To display the time history trace for a 
particular point, for example, it is easiest to select that joint before selecting the 
Display menu -> Show Time History Traces command. ETABS creates the time 
history display function automatically for that point. You can easily modify the 
component of displacement displayed if ETABS did not default to the one you 
want.  

We are interested in the deflection values if joints 2,4 and 6 in this example. Add 
these joints to the Vertical function column in the Time History Traces dialogue 
box. Click Define functions and select joint 2 and press Modify/Show TH 
function. Make sure the Displacement option is selected under the Vector Type. 
Repeat this step for joints 4 and 6. We are now ready to view the time history 
traces. See Figure 7-3: 
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Figure 7-3 Time History Trace Plot 

 

You can see that joint 2 has the most deflection, followed by joint 4 (the isolator 
frame system) and joint 6 (damped frame system).  

 Response Spectrum Curves 

After running a time history analysis, select one or more point objects and click 
the Display menu -> Show Response Spectrum Curves command to access the 
Response Spectrum Generation form. Use the form to specify the appropriate data 
to plot the various response spectra. 

Important Note: The response spectrum that you plot using this command is 
based on a time history that you have previously run. It has nothing to do with 
any response spectrum analysis that you may have run. 

There are many options available when viewing Response Spectrum Curves. 
These include Axes, Damping and Period/Frequency definition. See Figure 7-3 
for a sample Response Spectrum Curve. 
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Figure 7-4 Response Spectrum Curves Plot 
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EXAMPLE VIII Pushover Analysis Example 
 

  

Description 

This is a 2-D four-story steel frame structure, subjected to a static nonlinear pushover 
analysis. Each story is 12 feet high and each bay is 24 feet long. Nonlinear frame hinges 
are assigned to every frame element. The frame geometry is shown in Figure 8-1.  

 

Significant Options of ETABS Exemplified 

� Static Frame Hinge Definition 

� Static Nonlinear Pushover Case Definition 

� Pushover Curves 

  

  
 

Figure 8-1 3-D view of Pushover Structure 
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Computer Model Definition 

Static nonlinear (including pushover) analysis is a very powerful feature offered 
only in the nonlinear version of ETABS. In addition to performing pushover 
analyses for performance-based seismic design, this feature can be used to 
perform general static nonlinear analysis and the analysis of staged (incremental) 
construction.  Performing any nonlinear analysis takes time and patience.  

Hinge Property Definition  

Select the Define menu -> Frame Nonlinear Hinge Properties command to display 
the Define Frame Hinge Properties form. Frame Nonlinear Hinge Properties are 
used to define nonlinear force-displacement and/or moment-rotation behavior that 
can be assigned to discrete locations along the length of frame (line) elements. 
These nonlinear hinges are only used during static nonlinear (pushover) analysis. 
For all other types of analysis, the hinges are rigid and have no effect on the linear 
behavior of the member.  

The built-in default hinge properties for steel members are generally based on 
Tables 5.4 and 5.8 in FEMA-273. The built-in default hinge properties for 
concrete members are generally based on Tables 9.6, 9.7 and 9.12 in ATC-40. 
You should review any generated properties for their applicability to your 
specific project. 

Default hinge properties cannot be modified. They also cannot be viewed because 
the default properties are section dependent. The default properties cannot be fully 
defined by the program until the section to which they apply is identified. Thus, to 
see the effect of the default properties, the default property should be assigned to 
a frame element, and then the resulting generated hinge property should be 
viewed. 

For this model, we will use user defined hinge properties.  User-defined hinge 
properties can be based on default properties or they can be fully user-defined. 
When user-defined properties are based on default properties, the hinge properties 
cannot be viewed because the default properties are section dependent. When 
user-defined properties are not based on default properties, the properties can be 
viewed and modified.  

     Hinge Property Assignment 

Select the Assign menu -> Frame/Line -> Frame Nonlinear Hinges command to 
bring up the Assign Frame Hinges (Pushover) form. Choose a defined hinge 
property from the Hinge Property drop-down box. Type in a distance in the 
Relative Distance box (note the value must be less than 1). Click the Add button.  
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A hinge assignment consists of a hinge property and a location for that hinge 
along the frame element. The location is specified as a relative distance along the 
full length of the element measured from the i-end. The relative distance is equal 
to the distance from the i-end of the element to the hinge location, divided by the 
length of the frame element. Hinges may not be located within the end offsets. If 
the specified relative distance places a hinge within an end offset, the hinge is 
automatically moved to the inside face of that offset. 

     Static Nonlinear Pushover Case Definition 

Select the TDefine menu -> Static Nonlinear/Pushover Cases command to display 
the Define Static Nonlinear Cases form.  Static nonlinear/pushover analysis is a 
very powerful feature available only in the nonlinear version of ETABS. In 
addition to performing pushover analyses for performance-based seismic design, 
this feature can be used to perform general static nonlinear analysis and the 
analysis of staged (incremental) construction. Before an analysis can be run, the 
static nonlinear case must be defined. 

There are many options available when defining pushover case data. In this model 
we will be using most of the default values supplied by the program. We will 
enter a value of 25 inches in the Push to Displacement Magnitude box. Check the 
Push To Display. Magnitude check box to perform a displacement-controlled 
analysis. The load combination specified in the Load Pattern area of the form is 
applied, but its magnitude is increased or decreased as necessary to keep the 
control displacement increasing in magnitude. This option is useful for applying 
lateral load to the structure, or for any case where the magnitude of the applied 
load is not known in advance, or when the structure can be expected to lose 
strength or become unstable. If you want more specific information about each 
section of this data form, go to the Help section in ETABS and look under Static 
Nonlinear Case Data. 

Results 

    Pushover Curves 

After you have run a static nonlinear analysis, click the Display menu -> Show 
Static Pushover Curve command to access the Pushover Curve form.  The static 
pushover curve is a single force-displacement curve obtained from a static 
nonlinear analysis. View the pushover curve in the Acceleration-Displacement 
Response Spectrum (ADRS) format and overlay it with various response spectra, 
thus allowing you to perform capacity-spectrum analysis in ETABS.  

In our example, we view the deflected shape of the structure by selecting Display-
>Show Deformed Shape->select the pushover case-> Step 1.  By using the arrows 
on the bottom right hand corner of the screen, we can toggle step by step to see 
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the frames hinging. The colors of dots on the hinges change with each step. Each 
color represents a different stage in the pushover analysis. For example, a blue dot 
represents that the frame has reached the Immediate Occupancy Stage, a green dot 
represents Collapse Prevention and a red dot represents Failure of the structure. 
Please refer to Figure 8-2 and 8-3. 

 

 
 

Figure 8-2 Deflected Shape of Structure 
 

As seen in Figure 8-2, the columns on the bottom level show red dots on the I and 
J ends which signifies they have reached their capacity and the structure has 
collapsed.  The deflection at the top level is 23.47 inches. The pushover curve in 
Figure 8-3 displays the collapse occurring at the specified displacement. 
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Figure 8-3 Pushover Curve 
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environments. He has developed computer models on high rise structures in excess of 
100 stories and has provided design work on a variety of structural framing systems 
including base isolation and other complex framing systems. Mr. Tovani has been using 
the SAP and ETABS computer programs for over twenty-five years and has worked with 
CSI on example models and documentation. 
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Atif Habibullah has worked as a Software Support Engineer at CSI for the past 4 years. 
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